2
Error when adding/deleting users in an alias - Object reference not set to an instance of an object.
Problem reported by Veso Ganev - 3/10/2022 at 11:58 AM
Submitted
We have a staff alias that has about 45 recipients. Went on to try to add a user to the alias, but we get an error "Object reference not set to an instance of an object". The alias works as-is and it still forwards emails to the current user list, but we get the same error if we try to add or delete any users. 

So far, we've tried restarting the smarter mail service, rebooting the instance. Also confirmed other aliases work just fine. I can also copy the user list into a new alias with a new name without an issue. My next step would have been to delete and re-add the alias with the existing list, but I was worried that we may end up being unable to reuse the name, which is a problem as its a widely known/used alias.

We are running Build 8055 (Jan 20, 2022). 
Any ideas?


1 Reply

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Hello Veso, I am sorry to hear you are having these issues. Based on the behavior you've outlined, I believe you may have some corrupted or locked JSON configuration files within this domain or its aliases. You may be able to restore a backup copy of the JSON configuration files from this domain's Archived Data folder with the system service stopped, but recommend validating those JSONs before restoring them. Please let us know if you need any help tracking this down. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread