2
IceWarp to SmarterMail Conversion
Question asked by Vince - 1/23/2022 at 12:39 PM
Unanswered
Has anyone used the icewarp converter app, I have a copy that I downloaded last year, when I run the converter, it looks like it extracts the domains and creates user folder etc.  But when I edit the domainlist json file as described, smartermail tries to convert but doesnt complete when I look at the log, it doesnt give allot of information this is what I get.

[2022.01.23] 13:50:08.236 [ctcdsi.com] Could not find 'C:\SmarterMail\Domains\ctcdsi.com\settings.json' this domain will now be converted.
[2022.01.23] 13:50:08.258 [ctcdsi.com] Conversion started.
[2022.01.23] 13:50:09.124 [ctcdsi.com][Warning] Message: Detected no domain admin account specified as primary domain admin. Please set one in domain config settings in web interface after load.
[2022.01.23] Exception: None
[2022.01.23] 13:50:09.132 [ctcdsi.com] Converting 0 aliases...
[2022.01.23] 13:50:09.134 [ctcdsi.com] Converting 0 user groups...
[2022.01.23] 13:50:09.180 [ctcdsi.com] Converting mailing lists...
[2022.01.23] 13:50:09.280 [ctcdsi.com] Converting meetings...
[2022.01.23] 13:50:09.280 [ctcdsi.com] Converting 3 users...
[2022.01.23] 13:50:09.280 [ctcdsi.com] Converting user: justins (1 / 3)
[2022.01.23] 13:50:10.283 [ctcdsi.com] Converting user: robertq (2 / 3)
[2022.01.23] 13:50:10.298 [ctcdsi.com] Converting user: gavinn (3 / 3)
[2022.01.23] 13:50:10.445 [ctcdsi.com] Converting 0 events...
[2022.01.23] 13:50:10.461 [ctcdsi.com] Converting 0 notifications...
[2022.01.23] 13:50:10.481 [ctcdsi.com] Converting 0 resources...
[2022.01.23] 13:50:10.483 [ctcdsi.com] Converting 0 user mappings for justins...
[2022.01.23] 13:50:10.483 [ctcdsi.com] Converting 0 user mappings for robertq...
[2022.01.23] 13:50:10.483 [ctcdsi.com] Converting 0 user mappings for gavinn...
[2022.01.23] 13:50:10.615 [ctcdsi.com] Conversion finished in 2.36 seconds.

When Finished I look in the admin webgui the domain now shows, but when i click on the domain, it gives and error saying in red popup message "Object reference not set to an instance of an object" and the gui page for the domain is blank not even rendered no data or fields.

Anyone have any ideas?

Is there another way to migrate a domain from icewarp without doing an import of each account through the webmail.

3 Replies

Reply to Thread
1
Sabatino Replied
I made the conversions like this and they worked well

https://imapsync.lamiral.info/
3
CLEBER SAAD Replied
ImapSync it's the best software to migrate anywhere to Smartermail.
3
Tim Uzzanti Replied
Employee Post
We have a few large initiatives in 2022 and one of them is a tool to transition from Exchange much easier than it is today using a variety of tools and methods.  We anticipate this around mid year.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread