2
Backup MX rejects e-mail with "550 Mailbox unavailable. The server reponse was: <blah@blah.com> No such user here"
Question asked by LiamRetrams - 12/14/2021 at 7:37 PM
Unanswered
As in title

I've got two mail servers, one is the "main" one that our users connect to via EWS/IMAP/SMTP to receive/send emails.

The other is a backup MX, which is just a clean install of SmarterMail (latest version as of this writing) that has no additional configs. 

I find that when my main MX is down, if I try to send email the Backup MX will reject my email with this message:

11/12/2021 12:29:09 a.m.    Mailbox unavailable. The server response was: <username@domain.com> No such user here

Some details:
  1. My backup MX smartermail instance isn't licensed. Is there a requirement for it to be licensed?
  2. I configured the backup MX using this guide: portal.smartertools.com/kb/a3549/configure-smartermail-as-a-backup-mx-server.aspx
  3. My backup MX has proper forward & reverse DNS set - primary MX is priority 10, backup MX is priority 20.

I have manually connected to the backup MX on port 25 using an app that sends outbound emails, and tested several emails and 100% of them have been delivered into the primary and then into the users mailbox. The issue appears to only happen when the Primary is down. I'm reluctant to take down my primary just to test this without fully understanding the implications of why this happening to begin with.


So what gives? A "Backup" MX is pretty much useless if it won't accept mails when the primary is down right? Is this a configuration issue?

3 Replies

Reply to Thread
0
Scarab Replied
You can use the SmarterMail Free License for Incoming and Outgoing Gateways, including Backup MX. We have three incoming Gateways, one of which is a Backup MX all using the Free License serving our primary installation which uses an Enterprise License.

I suspect what may be happening is that you have the card "Enable SmarterMail Gateway Mode" enabled in your SETTINGS > GATEWAYS/FAILOVER on your Backup MX. If this option is enabled then the inbound gateway will check with the primary mail server to determine if a recipient email address is valid. If the primary mail server is down it obviously cannot do this and will result in the 'rsp: 550 Mailbox Unavailable' or 'rsp: 550 No Such User Here' NDRs that you are reporting. Turning this setting off should allow for it to work properly when Backup MX is selected for the Gateway Mode.
0
Zach Sylvester Replied
Employee Post
Hello, 

Thank you for reaching out to the community. 
Please verify that you have gateway mode enabled. 
1. Log in to SmarterMail on the backup MX as a system administrator.
2. Navigate to Settings>Gateways/Failover>Incoming Gateways.
3. Click New, and select Backup MX in the Gateway Mode field.
4. Configure the additional fields here including the IP address of the backup MX and any spam settings. Save when complete. 

Please let me know if this helps. 

Kind Regards, 
Zach Sylvester
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
LiamRetrams Replied
Scarab, thanks for the response. I read your reply, then the guide again, then looked at the config, now I think the guide may be wrong? 

The guide says:

1. Log in to SmarterMail on the backup MX as a system administrator.
2. Navigate to Settings > Gateways/Failover > Incoming Gateways.
3. Click New, and select Backup MX in the Gateway Mode field.
4. Configure the additional fields here including the IP address of the backup MX and any spam settings. Save when complete.

That doesn't seem right? On the "backup" MX system, shouldn't I set that uip in the "Outgoing" gateway, and not the incoming one?  

In my current config, on my Backup MX, I have my Primary MX configured under Settings > Gateways/Failover > Inbound Gateways. This seems incorrect? But this is what the guide says.

@ Zach, again I am confused. In step 4, when you say "including the IP address of the backup MX and any spam settings.", does that mean you want me to put in the IP of the backup mx ITSELF in this field (as system admin on the backup MX server).


Reply to Thread