2
Autodiscover SSL/TLS Problem with Thunderbird mail client
Question asked by David Costello - 11/3/2021 at 10:24 AM
Answered
Hello Folks, Hope you are doing all fine. 
I have Smartermail server with aoutodiscover , which is working good with Microsoft Outlook 2016. I am getting error while trying to add mail account via Thuntherbird mail client. Getting error like this :
and in manual configuration it looks like this

2 Replies

Reply to Thread
0
Zach Sylvester Replied
Employee Post Marked As Answer
Hello David, 

I understand that this post is old but I did some digging and found the answer to this. 
Firstly you need to set up a binding for autoconfig.yourdomain.com Microsoft requires autodiscover.domain.com but firefox is different and requires autoconfig. Next, you need to create a binding for 587. So go to Settings->Bindings->ports then make an entry for port 587 using TLS and use your PFX. After this you need to go to Manage->Clickyourdomain->Autodiscover Card then set click the gear next to SMTP in and set that port to 587 and use SSL.  I know that we have a checkmark for TLS but this just adds <TLS> On </TLS> to the autodiscover.xml which doesn't work. It does, however, work for IMAP so I'm not sure about that. I'm going to create a DEV task to look into why it doesn't.  But once you have completed all of these steps you should see this when you run the autodiscover in thunderbird. 
I am going to do some further testing regarding the need for the autoconfig vs autodiscover and see if thunderbird still needs this information. I got started down this rabbit hole after looking at this post. https://serverfault.com/questions/935192/how-to-setup-auto-configure-email-for-android-mail-app-on-your-server 

So we may need to update our DNS configuration help document but I'm not sure yet as autodiscover seems to work as well. I'll keep you guys posted on this forum discussion with what I find. 


Please let me know if this helps. 

Kind Regards, 
Zach Sylvester
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Zach Sylvester Replied
Employee Post
Hey Guys, 

Just following up on this, from my testing it looks like the autoconfig.domain.com isn't required on the newer versions of thunderbird. So you should be able to just use your autodiscover.domain.com record. 

Kind Regards, 
Zach Sylvester
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread