8
SmarterMail Incorrect DNS
Problem reported by Bruce - 9/29/2021 at 8:20 AM
Resolved
Since installing ASP.NET 4.8 on the server with SmarterMail in preparation for Build 7929 I have been getting lots of issues of incorrect DNS.

I am using a local Micorosft DNS server to do the DNS lookups which I have tested during the times below and is returning correct results. I also have DNS caching disabled in SmarterMail.

SmarterMail keeps getting the wrong DNS, for example in the last few days I have seen times when instead of finding 5 MX servers for Gmail it will find 0 or 1, and even use the IP 127.0.0.3 to try and send emails addressed to Gmail.com which then bounce.

The same issue with hotmail.com, on Sunday it thought for a while that the IP for Hotmail's mail service was an IP that belongs to Mailchimp causing all emails to hotmail.com  to bounce with a relay denied error message.

These are just a few examples, I have had numerous other DNS issues, it seems that SmarterMail at times is associating the wrong DNS response with the wrong DNS request.

I have around 12,000 mailboxes so the mail service is quite busy, and since ASP.NET 4.8 was installed on the server this issue of incorrect DNS is occurring every 48 hours. I have now updated to Build 7929 but the issue still occurs.

It seems to occur more often with popular domains such as hotmail.com and gmail.com which have low TTL and therefore DNS lookups occur more frequently.

The only way to fix the issues and get SmarterMail using the correct DNS is to restart the SmarterMail service.

I was wondering of anyone else is seeing the same issues?

8 Replies

Reply to Thread
0
Heimir Eidskrem Replied
After installing 7929 last Sunday, we had tons of DNS issues.
I thought it was our DNS servers so I changed the smartermail dns server to 1.1.1.1 and 8.8.8.8 and the problem seemed to have gone away.
Had no issues as far as I know since but its interesting you are reporting your issue.
We are using SimpleDNS internally and that was what smartermail was using.


H.

7
Andrea Rogers Replied
Employee Post
Hi Bruce, 

I've been told that this issue is not related to the .NET 4.8 update. In Build 7929, we updated a DNS component. This component is open-source and our development team has reviewed its code and believe to have found and fixed the underlying issue. As of right now, this fix within the DNS component is making its way through our QC process, and we're hoping to have a public release with this fix soon. We'll provide an update here when that new build is available. 

We'll also be passing this information to the creators of the DNS component so they can get this resolved on their end as well.

Andrea Rogers
SmarterTools Inc.
877-357-6278

www.smartertools.com

2
Scott Forsythe Replied
Voted up. We are also having DNS problems. SM restart is a temporary fix. Looking forward to the new build.
0
Bruce Replied
Thanks for the reply, Andrea.

I installed ASP.NET 4.8 on the mail server Friday while still running build 7914 as I did not want to also upgrade SmarterMail so close to the weekend and started seeing DNS issues Sunday with this previous build.

I only updated to the latest 7929 build Tuesday to see if this would fix the issue.

So it would seem that the issue also affects the previous version 7914  as well.
1
Bruce Replied
I believe I found a workaround for those affected by this.

From tests that I have run SmarterMail is caching DNS responses until the Time-To-Live (TTL) expires, so when it gets the wrong DNS to a query it holds on to this till the TTL expires. SmaterMail is ignoring the option to not cache responses set within SmarterMail interface.

As this issue occurs all the time for me I was able to test this by setting the maximum TTL on my DNS servers and then seeing how long SmarterMail would keep trying to send emails to Gmail to the wrong address. By lowering the maximum TTL SmarterMail reduced by the same amount the time it would send Gmail emails to the wrong IP.

As a workaround till SmarterMail fix the issue if you disable caching on your DNS servers it will then pass to SmarterMail a TTL of 0 for each DNS response, preventing SmarterMail from caching the wrong DNS response.

To disable caching for a Microsoft DNS server running the following from the command prompt on the server running your Microsoft DNS server;

Set-DnsServerCache -MaxTTL 0 -MaxNegativeTtl 0

To send a TTL or 0 to SmarterMail using SimpleDNS in options go to Resolver - Caching and set the maximum cache time for a positive response to 0
0
Bruce Replied
Even with the workaround still are getting the odd customer email being sent to the wrong mail server when the DNS gets the wrong IP for an MX record.

How soon will it be before a fix is available for this DNDS issue?
1
Zach Sylvester Replied
Employee Post
Hey Bruce,

Thanks for posting. Have you installed the latest build?
Looking forward to hearing from you. 

Best Regards, 
Zach Sylvester
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bruce Replied
Yes, I have all is working well with the latest 7945 build and no DNS issues so far.

Thank you.

Reply to Thread