2
SPF problem at gateway
Question asked by Kayasidh Kasyapanun - 8/10/2021 at 9:56 PM
Unanswered
    I have a server acting as both inbound and outbound gateway on the same SmarterMail installation (version 100.0.7887.30258 (Aug 5, 2021)). The setup that I see the issue looks like this.

user1 <--> mail server1 <--> inbound/outbound gw <--> mail server 2 <--> user2

    When user1 (home IP) sent an email to user2, the gateway performed an SPF check on the origin IP (home IP) instead of mail server1's IP. Note that mail server1 and mail server2 IPs are listed in inbound list of the gateway.

    When I removed mail server1 IP from the inbound list, the SPF checked correctly.

    What should I set/configure to solve this?


1 Reply

Reply to Thread
0
Kyle Kerst Replied
Employee Post
I believe this indicates that your gateway address is listed within Settings>Antispam>IP Bypasses. This will cause the spam checks to ignore that IP in the received chain, and scan the previous IP in the list instead. This would move the spam checks back a step from the gateway/server address to the original client IP address. I recommend submitting a ticket on this one so we can take a closer look at your setup and provide guidance. Have a good one!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread