4
MAPI sending mail has encoding corruption
Problem reported by Ben - 5/21/2021 at 1:51 AM
Submitted
(I did post a ticket to SM, but as they are closed now until Monday, I thought I'd post here to see if anyone else has the same and collect more data)

Since I upgraded to 7803, sending messages using MAPI is (sometimes) corrupting the special characters in them. I know it's not the inbox receiving part, because you can see the corrupted version of the message in the sent items folder.

For example:

Morning Ramesh 😊

 

I’ve done the upgrade on the server now – so you’re good to go with the email uploading!

Becomes:
Morning Ramesh 😊
 
I’ve done the upgrade on the server now – so you’re good to go with the email uploading!

Thinking about it, I guess it's possible it could be an issue when sending with non MAPI as well, but I have only noticed since I did the MAPI conversion for a large client.

Outlook 2016 and 2019 both give same results.

3 Replies

Reply to Thread
0
Gabriele Maoret - SERSIS Replied
It's seems to be solved in the subsequent release 7810:

Build 7810 (May 20, 2021)

....
  • Fixed: Special and accented characters might be improperly encoded in calendar appointments and invitations.
....
1
Ben Replied
I saw that, but it only mentioned appointments and invitations. Mine is happening with actual mail.

I'll try that update tomorrow morning though and see if it helps :)

Thank you!
1
Gabriele Maoret - SERSIS Replied
Oh, you are right! There's no mention of messages only calandars.

I must pay more attention

Reply to Thread