4
Messages missing from Sent Items
Problem reported by Jane Noel - 3/23/2021 at 8:16 AM
Submitted
We recently updated to 7719, but the client is saying he's noticed this for a few months.

I have a customer that's reported occasional emails that he sent missing from Sent Items. He contacted the recipient and the CC and they did receive the email.  But it is not in his Sent Items folder. (We also checked to make sure it wasn't accidentally deleted.)

It's happened to him (and a at least one other person in his domain) several times now. Not often...at first he thought he was doing something wrong, but this week he was diligent about checking and one went missing. We can see it in the mail logs and it looks like a perfectly normal email.  We know the CC and recipient received it.

Any one have any ideas?

Thanks,
Jane


23 Replies

Reply to Thread
0
Robert Emmett Replied
Employee Post
What client is the customer using to send messages?
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Jane Noel Replied
I know it's Outlook and he's sending from his computer (not phone), and I'm sure it's set up as IMAP.  I'll check to see what version of Outlook he's using.

0
Kyle Kerst Replied
Employee Post
I believe we had some issues in previous builds which resulted in some messages in sent items not displaying though they were physically present on disk. Is it possible this has since cleared up? 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Jane Noel Replied
No, this happened as recently as March 17th.

Would rebuilding the mailbox have an effect on this?

0
Kyle Kerst Replied
Employee Post
Jane, a rebuild of that folder may help recognize GRP content which is not being properly reflected in the mailbox.cfg for that folder. 

if the GRP files themselves (mail content) are present on the disk then we're likely looking at a problem with the mailbox.cfg file in that folder, and you can clear this up by stopping the service, renaming the mailbox.cfg to mailbox.cfg.old, then starting the service back up. This will reset all message flags, read/unread status, etc in this folder but should do a fresh index of what mail data is in the folder. 

If the GRP file itself is not present this would need to be restored to recover the mail data further. I hope this helps! If you need further help tracking this down I recommend submitting a ticket so we can dig into it with you. Have a good one Jane!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Jane Noel Replied
I've confirmed with the client he's using Windows 7 and Outlook 2016 set up as IMAP.

It's happening regularly, he found several emails yesterday that were not in his sent items. I checked the GRP file and the email is not there.  The missing email was at 3/17/21 14:24:24.  I can see emails from 13:24 and 15:14, but nothing from 14:24.

Wiping the times and dates of the sent items isn't really an option - that info is critical to him. Overnight, I will shut down the service and make a duplicate Sent Items folder to run a test on that.
0
Jane Noel Replied
I was able to duplicate his sent items folder, stopped the service, deleted the CFG files and restarted the service. I rebuilt the folder successfully.  The issue remains - the missing email is not in the rebuilt folder.

It feels like a miscommunication between Outlook and Smartermail?  Should I make a ticket on this?

Thanks,
Jane
1
Ionel Aurelian Rau Replied
@Jane Noel what build are you on? I`m curios if this is happening on the latest or not. This was definitely an issue that we too reported in an earlier build and which was subsequently fixed.
0
Jane Noel Replied
Ionel, we're on 7719.  Did you see this issue in that version?  What version are you running now? I see there are two more recent versions out just this week.
0
Ionel Aurelian Rau Replied
We`re running Build 7719 (Feb 18, 2021) as well, but did not experience it. We did a few builds prior to that.
0
Jane Noel Replied
Based on what my client is saying, he may have experienced the issue before the upgrade to 7719. (I have no proof of that.)  But I've never received any complaints previously.  And even now, it's one user complaining, and possibly one other at the same domain that may have an issue...but we have no details on that yet.
0
Kyle Kerst Replied
Employee Post
Jane, please do submit a ticket on this one so we can work a little closer together to get to the bottom of this. Please be sure to include access, the full username of the affected account, and date/time/from/to address information for the missing messages so we can try to track them down. Thanks Jane, have a good one!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Michael Replied
We're on. SmarterMail Enterprise. Build 7753 (Mar 24, 2021).
Several users (including me) reporting issues with sent messages not showing. We're looking further.

0
Jane Noel Replied
I had put in a ticket and we really didn't learn much more. I only had hard evidence of one that was missing (though I had vague complaints of others - just nothing that I could verify.)  We moved to 7761.  I haven't had any complaints since we upgraded.
0
Michael Replied
Humm... We'll keep looking. Possibly related on Outlook 2016 MAPI connected accounts, mail is hanging in the Outbox no error message. Just won't send.
0
Michael Replied
Seems to be isolated to MAPI in Outlook. 

If we send from EAS mobile device or IMAP (mobile or outlook) or SM webmail... messages show in Sent folder. 

They're only getting orphaned when sent from Outlook over MAPI. 

I'm talking to support now.

I'm a bit surprised not more static. Is it just that not many are using MAPI?
0
Tim Uzzanti Replied
Employee Post
MAPI is a heavily used protocol already but its fairly solid.  The issues that come up are just random emails (many of them malformed) that cause issues here and there.  We had one customer last week with an email with 400+ recipients that caused an issue.  It was one email out of a 15GB mailbox that caused the scenarios that we see from time to time.  Outlook doesn't like that number of recipients being sent over and we evaluated Exchange behavior and they send the first 100 recipients only to avoid Outlook from crapping out and we modified our MAPI implementation to do the same.  If your seeing any odd behaviors, please contact support because most of the issues with MAPI are very unique.  We need to look at the mailbox itself or network traffic to see if it is an email related issue, antivirus or configuration problem etc.  We think we have all the different Outlook integrated antivirus solutions supported now as well.  Each one acted a bit different and took us a little time to make SmarterMail respond just like Exchange.   Hope this helps...

Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Hovi jonn Replied
0
Michael Replied
@tim we stand ready happy to help see MAPI become stable. I think we have something like 5 open MAPI related tickets at the moment. It seems like we find a new issue at many corners. Perhaps due to the age of our server and the fact we have lots of mail/contact/calendar history over many SM versions?

Any way we can help please say or have Kyle reach out to me directly on any of those tickets.
2
Tim Uzzanti Replied
Employee Post
I am aware of one your tickets that has been escalated related to MAPI which is unique to your mailbox and we can't replicate.  The "view" in calendars saving between Outlook when closed and reopened when using MAPI is still in Microsoft's hands. We were able to find a way to keep the selected view while in Outlook.  You have two others that are EAS and EWS (not MAPI).  
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
info Replied
I updated yesterday to newest build (7776) and after this update we also have same problems like described before. We use Outlook 2016 and IMAP.

0
Tim Uzzanti Replied
Employee Post
Do you have a ticket for this?  I only see a ticket related to EAS / Flex Billing notification.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
info Replied
Hi Tim,
I will care about his.

Kind regards,
Uwe

Reply to Thread