5
Testing SmarterMail (7699) with EAS on Android smartphones --> no calendars, no contacts and many problems even with mails
Problem reported by Gabriele Maoret - SERSIS - 2/15/2021 at 7:39 AM
Submitted
We are testing SmarterMail EAS with some Adroid phones and we have these problems:
- no contacts are synchronized
- no calendar is synchronized

Scenario:

3 Samrtphone tested (1 Motorola with Android 10, 1 Nokia with latest Android 1 and 1 Samsung Galaxy Android 10)

Creataed a NEW user in Smartemail

Imported all user data from Kerio to SmarterMail using the tool in webmail CONNECTIVITY --> MAILBOX MIGRATION --> Kerio Connect

In Webmail and in Outlook (connected via MAPI) all data is OK, I see calendar and contacts

In all Android smartphones (connected via EAS) al the MAIL data is OK, but i don't have contacts and I don't have calerndar appointments (there's a lot of them in Webmail and in Outlook)...


NOTE: I don't have the Samsung smartphon anymore, but I can test more phones, like LG and Xiaomi...

Tested with Android Gmail App, Android Outlook App and Samsung Mail App.

There's no exceptions in EAS LOG on SmarterMail

11 Replies

Reply to Thread
1
Gabriele Maoret - SERSIS Replied
Tested another account in EAS, the customer send me this compliant e-mail (translated from Italian):

<<<<<<<<<<<<<<<<<<<<
With the phone's native Google app you can't get it going (Android ONE vers 10).
Removed and put back the account several times and also enabled / disabled the synchronization, everything appears for a while (both mail, contacts and calendar), you try to work a little on the mail and while you are doing something everything disappears and tells you that there are no messages (as if the inbox is empty) or it tells you synchronization in progress and does not snap. In any case it did not synchronize because in those few minutes that something could be done I deleted some e-mails which then promptly reappeared at the next synchronization.

Also tested on my wife's phone (SARA @) and the same thing happens (a few years old WIKO, Android 7.1.2)

On mine I tried with another app (BlueMail) to configure INFO @ and with this one it would seem to work (at the moment nothing has disappeared yet).
<<<<<<<<<<<<<<<<<<<<<<<<<<

It seems that SmarterMail EAS implementation don't work as expectd (they were before on Kerio Connect and everything were working perfect)
0
Gabriele Maoret - SERSIS Replied
I have opened a ticket for this issue
0
Webio Replied
One thing from my end: can you check data transfer usage of email app? I had no bigger problems with EAS on my Samsung S9+ with Samsung Email app but recently I've switched to Huawei P30 Pro and in few days Huawei Email app used almost all of my mobile data, I've switched to GMail app and also had issues with email, contacts and calendar sync. I've moved back to Huawei Email app and disabled mobile data for it. In WiFi usage I see values between 4 and 7GB per day just for Email app. Whole mailbox usage is 16.4GB so having this kind of usage is very weird. I was wondering about opening a ticket but I didn't had any issues on my Samsung phone so I thought this might be P30 Pro related (but still I had problems with GMail app too connected to EAS account). Can you keep us updated with your ticket responses? You can forward someone from ST crew if they will need another ticket from me.

EDIT: Just to clarify I was even removing all of my devices from synced devices in mailbox webmail configuration but nothing changed.
2
Gabriele Maoret - SERSIS Replied
UPDATE: SmarterTools told me (via ticket) that they are working on a new update that will bring the EAS protocol from the current version 14.1 to the latest version 16.1.

This should solve the various problems encountered (hopefully ...).

The release is expected in days (they told me mid-February ...)
2
Stefano Replied
I just hope that the new build will bring benefits and not more problems 😉
1
Douglas Foster Replied
This is not a new problem with this build, it has been around for at least 18 months.   It is new to this user because they have not tried the feature before on the problem phones.,

Older Android phones have two Exchange clients, one from Google which uses the GMail red "M" logo, and one from Microsoft that is blue.   The Microsoft client has always worked well.   Starting with the Pixel 2, the Microsoft Exchange client disappeared from new phones.  Without the Microsoft client, connectivity over ActiveSync is a problem.
1
Webio Replied
I'll wait for new release but on my end in adding accounts section on Huawei P30 Pro I see both options for Exchange mail. Exchange with Google Gmail icon (M) and blue icon with "E" and I tried both of them and ended up with the same issues.
0
Webio Replied
Hello,

does this has been addressed in latest 7719 build?

Thanks
0
Gabriele Maoret - SERSIS Replied
Hi Webio! I don't have any info about solutions to this issue right now...
0
Webio Replied
Have you maybe asked them in your ticket if this has been addressed in latest 7719 build update?
0
Gabriele Maoret - SERSIS Replied
It's not addressed yet

Reply to Thread