2
Any ides what would cause the Chat Link Wesbite integration to error?
Question asked by bemi khan - 1/19/2021 at 9:53 AM
Answered
Hi. I am getting the following error when testing the chat link on an external website. Any ideas to this? I am looking at options for a help desk and need something that works well with out systems. Thanks

ChatLink.ashx?config=1&id=stlivechat1:5 Uncaught TypeError: l.GetValue is not a function
    at HTMLDivElement.v.GetCustomFieldsString (ChatLink.ashx?config=1&id=stlivechat1:5)
    at ChatLink.ashx?config=1&id=stlivechat1:5

3 Replies

Reply to Thread
0
Lim Ryan Replied
I am facing the same issue on my website and also looking for a working solution if possible. Thanks
0
Andrea Rogers Replied
Employee Post Marked As Answer
Hello, 

This type of error indicates that the call back is missing some of the data. In the Live Chat > Website Integration settings, you'll find options available for configuring your live chat link. Can you confirm that you have created a unique live chat link, and the the Website Integration settings were modified before copying the website code? 

Please also ensure that the integration code is placed right before the page's ending </body> tag. The smaller portion (<div id="stlivechat0"></div>) can be placed on any shared page within the website. 


I didn't find an account for you in our customer database. Please reach out to our Sales Team by emailing sales @smartertools.com to get started with a 30 day trial of SmarterTrack. A trial license will allow you to test out the full functionality with as many agent accounts as you need. Once that correspondence has been started with the sales team, we can work with you directly to answer your questions and provide more information about the help desk software. 

Kind regards,

Andrea Rogers
SmarterTools Inc.
877-357-6278

www.smartertools.com

1
Sébastien Riccio Replied
Andrea, I think these are only to spam the forum with their websites links. There are a lot of these kind of posts recently.
All the same pattern, asking a question that looks legit and slide in a link. They even respond to their own thread with another spammy link, all from new accounts freshly created.
Same thing here: https://portal.smartertools.com/community/a93877/api-integration-problem-.aspx

Sébastien Riccio
System & Network Admin

Reply to Thread