5
Daylight Savings issue
Problem reported by Eric Tykwinski - 11/4/2020 at 9:03 AM
Submitted
Seems to be affecting IMAP and ActiveSync.  MAPI is showing correctly.

SmarterMail Enterprise
Build 7593 (Oct 15, 2020)
                   
Example from my Desktop and Server to show both are correct:
Server
PS C:\Users\Administrator> Get-Date -Format "dddd MM/dd/yyyy HH:mm K"
Wednesday 11/04/2020 11:00 -05:00

Desktop
PS C:\Users\eric> Get-Date -Format "dddd MM/dd/yyyy HH:mm K"
Wednesday 11/04/2020 11:01 -05:00

Email headers:
Received: ; Wed, 4 Nov 2020 10:31:47 -0400
From: "Eric Tykwinski" <eric@truenet.com>
To: "eric-list@truenet.com" <eric-list@truenet.com>
Subject: Test 2 10:31AM
Date: Wed, 4 Nov 2020 10:31:47 -0500
reply-to: eric@truenet.com
Message-ID: <ec1bf482eac149ee9dddb02bcfbd0494@>
MIME-Version: 1.0
Content-Type: multipart/alternative;
 boundary=4cba56a8b42a4cc68df8cec62e5ade8a
X-SmarterMail-TotalSpamWeight: 0 (Authenticated)

As you can see Outlook has the right date in the Date header, but it's showing the received date in IMAP on Outlook 2016 which is incorrect.

6 Replies

Reply to Thread
0
DAVE Replied
What we can reproduce and wanted to see if others can reproduce to help diagnose.??
SM Enterprise Build 7593
For example:
Send email from webmail to a user on the same SM server (or self)
check that message in Outlook  - Time is off 1hr.
Thanks
1
Liam Dwyer Replied
We are also experiencing this issue...  It seems to be when email is sent via MAPI, ActiveSync, or Webmail and then viewed in Outlook.  Below are the raw headers from two examples. 

Received: ; Thu, 5 Nov 2020 09:30:24 -0400 
From: "--------" <XXXX> 
To: <XXXXX> 
Subject: Test 
Date: Thu, 5 Nov 2020 09:30:24 -0500

Received: ; Thu, 5 Nov 2020 10:39:02 -0400 
From: "-----" <xxxxx> 
To: <-----> 
Subject: Test 
Date: Thu, 5 Nov 2020 10:39:02 -0500
3
Liam Dwyer Replied
I did some troubleshooting and have found a work-around.  It appears to be related to how Smartermail deals with the DST time-zone on the server when accessed via Webmail, ActiveSync or MAPI.

If you set the SERVER Windows timezone to a non-DST timezone, and restart SmarterMail, the issue goes away.
1
Michael Replied
Good hunting to find all that. Hope to hear from smarter tools on this soon.
2
Michael Replied
Anyone seeing this on latest release Build 7611 (November 2, 2020) ?
1
Tim DeMeza Replied
We have the same issue.  Also experiencing an issue where all of a sudden webmail users are logged out after a certain period of time. Seems related to the timing of this update.  Very strange as it never did this before.

Reply to Thread