Problem reported by Adam - 10/21/2020 at 8:57 PM
On an upgrade to SM latest yesterday, the new build didnt work correctly, not sure why.. even after I applied the same HTTP to HTTPS rule of web.config.....so I uninstalled then reinstalled previous version....I again put the same HTTP to HTTPS rule of web.config and it threw a 404 and wouldnt work with that same code ive been using for years, so I took it out and works back on old build..but no http to https redirect (important).

Any ideas as to why?

More importantly, can someone share their knowledge on this redirect rule and where precisely to put it in the upgraded web.config after update of SM? I really dont understand why this isnt default - we should all be running on HTTPS as default by now ST.

Thanks in advance :)

2 Replies

Reply to Thread
echoDreamz Replied
Marked As Resolution
We just enable the Force HTTPS option in SmarterMail for the domain and it handles the redirection for us.
Adam Replied
Oh yes thats great, thanks a lot! The only one generic domain that all customers use for webmail, I added it to the list of domains and ticked that option and working a charm again :)

Reply to Thread