3
CPU Utilization 100% after Build 7537 installed
Problem reported by Brian Davidson - 8/26/2020 at 4:00 AM
Resolved
After updating to build 7537 (Aug 20, 2020) we are seeing 100% CPU utilization. Anyone else having this issue? The only error in the logs appears to be a registry error (below). We are going to attempt to roll back to the previous build to see if that helps.

--
[2020.08.26] 05:38:37.602 Exception in MailServerStats.UpdateRealTimeStats -- System.UnauthorizedAccessException: Access to the registry key '230' is denied.
[2020.08.26]    at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
[2020.08.26]    at Microsoft.Win32.RegistryKey.InternalGetValue(String name, Object defaultValue, Boolean doNotExpand, Boolean checkSecurity)
[2020.08.26]    at Microsoft.Win32.RegistryKey.GetValue(String name)
[2020.08.26]    at System.Diagnostics.PerformanceMonitor.GetData(String item)
[2020.08.26]    at System.Diagnostics.PerformanceCounterLib.GetPerformanceData(String item)
[2020.08.26]    at System.Diagnostics.PerformanceCounterLib.GetCategorySample(String category)
[2020.08.26]    at System.Diagnostics.PerformanceCounterLib.GetCategorySample(String machine, String category)
[2020.08.26]    at System.Diagnostics.PerformanceCounter.NextSample()
[2020.08.26]    at System.Diagnostics.PerformanceCounter.NextValue()
[2020.08.26]    at MailService.Core.MailServerStats.UpdateRealTimeStats(Process mailServiceProcess)
[2020.08.26] 05:38:37.602    at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
[2020.08.26]    at Microsoft.Win32.RegistryKey.InternalGetValue(String name, Object defaultValue, Boolean doNotExpand, Boolean checkSecurity)
[2020.08.26]    at Microsoft.Win32.RegistryKey.GetValue(String name)
[2020.08.26]    at System.Diagnostics.PerformanceMonitor.GetData(String item)
[2020.08.26]    at System.Diagnostics.PerformanceCounterLib.GetPerformanceData(String item)
[2020.08.26]    at System.Diagnostics.PerformanceCounterLib.GetCategorySample(String category)
[2020.08.26]    at System.Diagnostics.PerformanceCounterLib.GetCategorySample(String machine, String category)
[2020.08.26]    at System.Diagnostics.PerformanceCounter.NextSample()
[2020.08.26]    at System.Diagnostics.PerformanceCounter.NextValue()
[2020.08.26]    at MailService.Core.MailServerStats.UpdateRealTimeStats(Process mailServiceProcess)


8 Replies

Reply to Thread
1
Patrick Mattson Replied
Had the same thing got a beta 7542. That brought my CPU down a bit, not to levels before 7537. I got a link from support if you want to try it.
0
Robert Emmett Replied
Employee Post
@Brian, please contact support, and they can provide a hotfix for the IMAP CPU utilization
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Brian Davidson Replied
Thank you Robert.
0
Brian Davidson Replied
Marked As Resolution
Just to follow up the hot fix provided to me worked like a charm. Support was extremely quick to reach out and help, which I greatly appreciate!
0
Patrick Mattson Replied
Are you running 3542? My CPU went from 8% daily to 40%, now with Build 3542 I am steady at 25%. Plus my memory usage is up quite a bit too.
0
info Replied
I updated to 7542, but now I habe problems with outlook 2016 and 2019 (MAPI) and IMAP (long time till snyc).
I made a ticket.

0
info Replied
Update to my last response. After downgrade to 7523 and upgrade to 7542 again all looks good. So perhaps it was a server issue.

1
Brian Davidson Replied
To clarify, I'm now on Build 7542 via the support provided hot fix. Since installing about 24 hours ago, I'm seeing normal CPU and memory usage again.

Reply to Thread