Outgoing Gateway
Question asked by Carlos Sosa - 7/16/2020 at 8:08 PM
Unanswered
Hello.

I'm running SM 16. with multiple domains.  I have a question about the Outgoing Gateway. 
If I setup an outgoing gateway and I enable it - Does SM automatically start using this outgoing gateway for all domains or only on those domains where I have selected the Outgoing Gateway under - Domain Settings? The reason I ask is because I have a domain that under domain settings - Outgoing Gateway, the NONE option is selected however it seems like the outbound messages for this domain are being sent through the Alternate Outgoing Gateway.

I would like to use the Alternate Outgoing gateway just is some domains and not in all of them. Is this possible?

Regards.

Carlos


7 Replies

Reply to Thread
0
Long Chung Replied
First,go to Settings-->Gateways / Failover-->you can create custom gateway

you can go to Manage-->Domain-->you want to set Domain-->outbound gateway select your Custom gateway.

In this way, only this domain will use the gateway you set up to go out.

if your Domain outbound gateway select "None",use the gateway of your own server.



0
Carlos Sosa Replied
Hi Long Chung. Thanks for the info.

I have a Custom Outbound Gateway setup for some domains, For those domains it is working well. 

However I have selected NONE for the outbound gateway for one Particular domain, however SOME (Not all) of the emails sent through this domain are being sent through the "custom outbound gateway" even though the custom outbound gateway is not selected in this domain settings (the NONE Option is selected). I think if the message being sent has a large attachment for some reason it uses the Custom Outbound Gateway to send the message. 

I was thinking in setting another Custom Outbound Gateway that points to the local server (localhost) and then selecting that in the Domain's Settings. - Not sure if this would work or how to set it up.   

Any ideas?

Thanks again.

Carlos
0
Long Chung Replied
My test will not have the problem you said, unless you choose "Round robin" will use both. what is your SM detailed version number? If it is already a new version, you may have to issue a support ticket and ask relevant personnel for assistance
0
Carlos Sosa Replied
Hi Long Chung

I'm running SM 16.3.6989. I don't have the Round Robin option selected (Its not even an option on this version)

Thanks for the help.

Regards.

Carlos
0
Long Chung Replied
There should be problems with the previous version, it is recommended to update the latest version, you should also ask you to update the version if you issue a support ticket.

Additional notes: I also tried to set a gateway for the server itself, but failed
0
Long Chung Replied
Ask again Why do I need to use an external gateway?

I used to "return message 601" many times, so I can only use an external gateway to solve this problem, but I finally found a solution
0
Carlos Sosa Replied
Hi.

I can confirm that SM uses the Custom Outbound Gateway to send the message when the email has an attachment - If I don't attach a file SM uses the local gateway otherwise it uses the External Gateway (This only happens for those domains where Outbound Gateway its set to NONE in Domain Settings)



Reply to Thread