3
Outbound gateway not being used for domains not set up in Smartermail
Problem reported by Richard Wilson - 7/3/2020 at 5:16 AM
Submitted
Hi, I run both a small mail server and a web server and I use the Smartermail web server to send outbound messages for the websites. The Smartermail server uses Sendgrid as an outbound gateway. The problem I have from moving to the latest version of SM is that if the domain isn't set up in Smartermail, the outbound gateway isn't used and it tries to send from the local server which fails (the cloud host doesn't allow it). Only domains that are configured in Smartermail use the outbound gatway. This appears to be a change between version 7242 and 7482. Is this expected behaviour or is this a bug?

3 Replies

Reply to Thread
0
Talha Anwar Replied
Hi,

Did you find a solution to this? I have the same problem
0
Kyle Kerst Replied
Employee Post
This is an expected behavior. SmarterMail uses the domain's settings to determine which outbound gateway should be utilized, and so if the domain isn't physically present on the server it won't know to use that gateway unfortunately. 
Kyle Kerst System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
1
Matt Petty Replied
Employee Post
Just spitballing here but you might be able to add an empty domain with the desired options set in the meantime. You may have to tweak some other domains settings such as the "Inbound message delivery".
Matt Petty Software Developer SmarterTools Inc. (877) 357-6278 www.smartertools.com

Reply to Thread