Build 7459: All contacts lost on iOS v 13.4.x
Problem reported by DarrenL - 6/9/2020 at 1:10 AM
Resolved
All contacts have disappeared connecting via EAS on any iOS devices running 13.4.x, devices running 12.4.x do not appear to be affected.  
SmarterMail Webmail - shows contacts ok.  
Apple contacts 12.0 - no contacts.

Tried deleting account and recreating, still no contacts.

Any ideas?

8 Replies

Reply to Thread
0
Craig M Replied
Same issue with us.  We upgraded to 7459 last night from the previous production version 7242.  Everyone's EAS contacts are gone on their mobile devices.  This is on both Android and IOS devices.  The contacts are still on the server but were removed on mobile devices.  We have also tried removing and re-adding the EAS account which did not fix the issue.  This is a HUGE issue, we've been getting emails all morning.  No one knows phone numbers to call or text people.
2
Chris Replied
Have your users go into webmail => Settings => Connectivity => Under Synchronized Devices => open and delete iPhone (EAS)

On the users phone, have them reboot the phone.

Under extreme circumstances, repeat the steps above, remove the EAS account for the iPhone, and reinstall. 
0
Craig M Replied
Chris, thank you that worked!  I also did hear from SM Support that the developers are working on the issue so hopefully we will have a global fix soon but at least I'm able to manually fix the clients that are desperate for their mobile contacts back.  Thanks again!
0
Sébastien Riccio Replied
Hello. Thank you for these infos. We also start seeing customers opening tickets about lost contacts on their iPhone. I hope the global fix will be available soon, crossing fingers.
Sébastien Riccio
System & Network Admin

0
Robert Emmett Replied
Employee Post
Thank you, everyone, for reporting this issue.  I have been able to replicate the issue when syncing an existing EAS connection on SM15 then upgrading that server to the latest build.  The device removes the contacts, passing back the existing sync key, and the server is not pushing the contacts back to the device.  We are investigating this behavior. I will help this thread updated with what we find.

A workaround in the mean time is to performing the following. Please note that the account MUST be removed from the device AND from the Sychronized Devices in the web interface.

  1. Remove the connection from the device/client
  2. Login as the user (or impersonate the user) 
  3. Go to User Settings -> Connectivity -> Synchronized Devices card
  4. Find your device/client and delete the connection. 
  5. Now you should be able to add the connection back to the device. 
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Robert Emmett Replied
Employee Post Marked As Resolution
I have found a solution for this issue that does not require users to remove and readd their accounts.  The root of the problem was how SmarterMail referenced the ids of folder between SmarterMail versions. The older ids could not be found against the new format and was returning an empty list of contacts.  The fix will be in the next public release of SmarterMail.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Sébastien Riccio Replied
Hello Robert, that's great news ! Thank you.


Sébastien Riccio
System & Network Admin

0
Matteo Replied
Hello, update to build 7468 solved the problem? Same error here :(

Reply to Thread