2
Can’t reach this page - http://127.0.0.1:9999/ nor http://localhost.1:9999/
Problem reported by Salam ELIAS - 3/25/2020 at 7:23 AM
Resolved
Hi, I downloaded ans setup the free version, install went through (during installation I pointed to 1 virtual application), at the end IE opened, was not able to reach http://localhost.1:9999/. I searched this site "Getting started" but there is no hint to help.
Am I missing something to configure? Even I disabled my firewall but still not able to access SmartStats.

Thanks for your help

5 Replies

Reply to Thread
0
Salam ELIAS Replied
I removed and reinstalled SmartStats but this them I did Create New web site, web site created but still when I browse by host name or ip I get the same error
0
Kyle Kerst Replied
Employee Post
Hello Salam, can you open up the IIS Management Console and check the Bindings of your installed site? You'll want to make sure the hostname reflects localhost and the port is 9999, then you should be able to access that site via this link on the server itself: 


If that doesn't work it is possible you have an antivirus or firewall/security solution blocking access on this port. Please let me know what you find out on this. Have a great day!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Salam ELIAS Replied
Thanks, in fact, I reinstalled third time, I did check this, I updated my hosts file with the host name I gave and now I am able to access it.
I am wondering why in your documentation, Get Started, you do not give hints or explanation on the 4 options we can use .
In fact the 1st time when I pointed to an existing web site, it deleted the contents and established itself there. Hopefully it was a test site and did no harm, so you really need add this to your getting started explanation for installing
0
Kyle Kerst Replied
Employee Post
You're welcome, I'm sorry to hear you had so much trouble with this. Ideally when installing SmarterMail you'll want to create a new site, unless you already have an existing SmarterMail site set up in which case you can have it configure an existing site. Previously SmarterMail included a built in web server, but being that this is no longer pre-packaged with the product you do need to have some IIS knowledge to work with the product. Please don't hesitate to ping us/our community if you have any other questions along the way. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
David Sovereen Replied
I ran into the same thing.  I think the issue is that the installer is not clear about what it is asking.  All it says is "Internet Information Services Configuration."  I thought, and I think Salam thought too, that the installer was asking us which site we wanted SmarterStats to analyze.  I did not know that SmarterStats was creating a web site for itself.  I, too, had it overwrite my own web site (which was the site I wanted SmarterStats to analyze) with its own.  The installer should explain that the program is web based and needs to create an IIS web site for you to access it.

Now when I re-run it and tell it to create a new site, it doesn't create a site. I re-ran the installer twice and nothing.  I've manually created a site, bound it to localhost:9999 and pointed it to the MRS directory, and get this error:

HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

Most likely causes:
A default document is not configured for the requested URL, and directory browsing is not enabled on the server.

Things you can try:
If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
Enable directory browsing using IIS Manager.
Open IIS Manager.
In the Features view, double-click Directory Browsing.
On the Directory Browsing page, in the Actions pane, click Enable.
Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.

Detailed Error Information:
Module       DirectoryListingModule
Notification       ExecuteRequestHandler
Handler       StaticFile
Error Code       0x00000000
Requested URL       http://localhost:9999/
Physical Path       C:\Program Files (x86)\SmarterTools\SmarterStats\MRS
Logon Method       Anonymous
Logon User       Anonymous

More Information:
This error occurs when a document is not specified in the URL, no default document is specified for the Web site or application, and directory listing is not enabled for the Web site or application. This setting may be disabled on purpose to secure the contents of the server.
View more information »
I looked for a KB on what the correct IIS settings are, but didn't find one.
Ideas?
Thanks,
Dave

Reply to Thread