Out of office email fails from SmarterMail when using Exchange Online Protection (Office365) as the incoming gateway
Question asked by Long Huynh Minh - 3/15/2020 at 12:13 AM
Unanswered
Dear,

We have set up a 'hybrid' mail between Office365 <-->SmarterMail for the entire domain. Incoming gateway via Exchange Online Protection (EOP), outbound gateway sent directly from SmarterMail.

All send and receive in both directions work fine until we use the Automatic Replies feature for any mailboxes.

For example, we have the domain sayobe.com with demo@sayobe.com mailbox enabled autoresponder. Specifically: when we use the incoming gateway through Exchange Online Protection, all mail from external organizations is sent via the EOP system (check spam and virus before receiving) and forward all mail to the main Mailserver (SmarterMail) with forwarding address names usually begin with bounces+srs=xx=xx@domain.com (a representative address to forward all filtered mail to the received address).

However, with the auto-reply enabled mailbox, the SmartMail system will automatically reply for bounces+srs=xx=xx@domain.com address (This is not the actual sending address that the address used to forward from the EOP system, if you understand correctly, the automated mail must be sent to the (real) sender outside.

Has anyone encountered this situation like us? If so looking forward to the help.

Kind regards,

Reply to Thread