HTTP to HTTPS redirection of the web interface
Problem reported by Gabriele Maoret - SERSIS - 3/4/2020 at 9:01 AM
Submitted
We can't find a way to make a persistent HTTP to HTTPS redirection of the web interface.

I have configured IIS to make HTTPS redirection. it work really good, but apparently at every SmarterMail new version upgrade it is removed by the SamrterMail installer (we use te EXE version) and I have to reconfigure it.

There's a way to make it permanent?

5 Replies

Reply to Thread
0
Gabriele Maoret - SERSIS Replied
Forgotten to tell that we are on the latest production beta
0
Robert Simpson Replied
I have IIS configured so that the mail server runs as its own site, via https bindings only.  Then I setup a second IIS site with only http bindings that directs to the https address.

That way when SM updates, it updates my main IIS mail site and leaves the redirect IIS site alone.

1
Gabriele Maoret - SERSIS Replied
Hi Robert, thanks.

I think your suggestion could be a workaround, but it's not a good solution beacuse it forces us to manage 2 sites, 2 DNS entry and 2 configurtion while it's not a normal situation in a server enviroment.

I think that SmarterTools must get in touch and give us a way to manage the https forcing option.
0
Steve Norton Replied
@gabriele-maoret-sersis
Hi,
Have you referred to https://portal.smartertools.com/kb/a3246/force-webmail-traffic-over-https.aspx
Are you saying that you have a port 80 binding on your site and when you upgrade you choose 'Use existing' and the port 80 binding is removed?
Along the lines that @robert-simpson has suggested you could have the 'Default Site' bound to port 80 and redirect from there, it doesn't require any maintenance going forward and will use the same DNS name. This is a recommended security configuration rather than having your SmarterMail site bound to port 80.
0
Gabriele Maoret - SERSIS Replied
ok, tomorrow I will try

Reply to Thread