SM 15.x Connect To SM17x ?
Question asked by Merle Wait - 1/14/2020 at 12:33 PM
Unanswered
We currently have two licensed flavors of SM.   SM15.x (still our primary -as far as SM goes) ....
.. and SM17x (secondary - still in testing)

SM17X - apparently can not authenticate to SM15x   for outbound gateways.
I opened a ticket.
STools  - recommending changing the outbound to SM17x.   As I explained in the ticket back... 
Its easy just to say "Upgrade" .... but if SM15x can't talk to SM17x ... we will be dead in the water .. immediately.

So my question is ... has anyone else had luck connecting SM15x --> to SM17x?  
We can not, at this time, get SM17x ---> to authenticate to SM15x outbound, so am very skeptical 15x --> to 17x works.



3 Replies

Reply to Thread
0
echoDreamz Replied
While I cannot comment on your issue, we migrated away from using SM as the outgoing gateway, we use ZoneMTA now on Linux as our outgoing gateway and it works brilliantly.
0
Christopher Hiatt Replied
I'm trying to just get a SM16 to SM16 relay to work with no luck. Was also testing SM17 before purchase and can see if I can get an SM16 to SM17 to work but guessing no on that too.
1
Christopher Hiatt Replied
I can't confirm for your scenario but I was able to get SM16 and SM17 to do this. I'm testing this today and this is how I have it working.

The SM16 is the primary mail server.
The SM17 box is the free, single domain version with a dummy domain setup for inbound filtering.

Both boxes have SSL/TLS enabled and bound to ports 25, 465, 587 and 993. I have MX records pointing to the SM16 box as primary, and the SM17 box as secondary. Both boxes have the LOCAL IP address of the other box in security IP whitelist settings for SMTP bypass. (Note I have both boxes connected via VPN. If connecting the two across public IP then use their public IP addresses instead)

For the SM16 primary mailserver in Gateway settings I just added an external gateway with the IP of the SM17 box on port 465, enable encryption, priority all. Do not enable authentication or turn on gateway mode.

For the SM17 box I added an internal gateway using domain forward mode. Entered the IP of the primary mailserver, status enabled. I'm using all (web service) for domain verification. Enable gateway mode and enter the full URL of the primary mailserver. Enter the user name and password of a Smartermail Admin. Not a domain admin and turn on web service user verification.






Reply to Thread