Problem with outgoing gateway per domain.
Problem reported by Wiphu Leelasitorn - 1/8/2020 at 1:23 AM
Submitted
I have added an outgoing gateway to smtp.sendgrid.net
There are two domains in my SmarterMail, domain1 and domain2.
I configured domain1 to use smtp.sendgrid.net as outgoing gateway while I left domain2 to use "Default" as outgoing gateway.

I tried send emails from both domain1 and domain2 and the result was emails from both domain1 and domain2 was sent through smtp.sendgrid.net

From my understanding, domain2 should be sent by SmarterMail SMTP server.  Please advise.

7 Replies

Reply to Thread
0
Information Technology Replied
Not sure if your issue is the same as ours but when we started using outbound gateways configured on a per domain basis we were no longer able to use "Default" as the gateway. In our scenario, domains set as default couldn't send mail at all. 

I did post this issue in the forum but never got a reply. Possibly because the solution we put in place was the correct solution. You can install Smartermail on another server, without licenses, to act as an email gateway for all domains not using sendgrid.
0
Emily Ward Replied
Employee Post
Hi Wiphu,

In your outgoing gateway settings, do you have the Type set to "Round Robin" or "Specific Domains"?  

Edit: In your outgoing gateway settings are you using the IP address as the Server Address or are you using smtp.sendgrid.net?  The Server Address you use for the outgoing gateway should be the IP address of the gateway server.
Emily Ward
Customer Relations and Partner Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
echoDreamz Replied
If you are using the MAPI beta, I'd suggest not enabling outgoing gateways, they are broken right now.
0
Wiphu Leelasitorn Replied
My SmarterMail version is SmarterMail Enterprise Version - 100.0.7016
I configured domain1 to use smtp.sendgrid.net with type "round robin".  My SendGrid plan doesn't have dedicated IP address, therefore I couldn't use IP address as Server Address.

domain2 uses "Default".

Both domain1 and domain2 are sent through smtp.sendgrid.net
0
Emily Ward Replied
Employee Post
Wiphu,

Change the Type to "Specific Domains".  See if that helps.
Emily Ward
Customer Relations and Partner Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
John Marx Replied
We are set to specific domains and we still have mail going out from the server ip address.
0
Douglas Foster Replied
How sorry I am to hear that you use sendgrid.net.   Most of what they send me is spam, but a few senders are legitimate, so I cannot blacklist them completely.

I am working to roll out a Declude rule that gives me the granularity to allow only those few sender's to het through.

Reply to Thread