Unable to run Clam virus checks (V.15.7.6638 on W2016) - libclamav.dll missing + SocketException
Problem reported by Mars _ - 12/31/2019 at 3:53 AM
Submitted

Hello,


we transferred a SmarterMail V.15.7.6638 installation from an older Windows 2012 to a new server running W2016 (both virtual machines).

Since then the windows system log shows the following informational messages ->


Application popup: clamd.exe - System Error : The program can't start because libclamav.dll is missing from your computer. Try reinstalling the program to fix this problem.


SmarterMail delivery logs shows the following:


Unable to run Clam virus checks: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 127.0.0.1:3310

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)

at MailStore.Spam.ClamDClient.CheckScan()



Both Visual C++ Redistributable 86+64 are installed, firewall ports opened.


Will this errors be gone if I upgrade to the lastest build 

or is it advisable to get rid of the problem in advance?


Thanks and happy new year?
Gerhard

4 Replies

Reply to Thread
0
Sébastien Riccio Replied
Hello,

How did you transfered the SmarterMail installation. Did you run the SmarterMail installer on the new server and then transfered all data files ?


Sébastien Riccio
System & Network Admin

0
Mars _ Replied
Hello,
yes  - installed the identical version of SmarterMail on the new server and transferred all domain data and smartermail/service content. 


0
David Fisher Replied
Mars,

  You know you are not running the latest v15.7.6970 release, there have been 14 point releases since the one you are running.  I would suggest downloading the latest/last v15.7.6970 release and running the installer over it, that might fix things.

   If you cannot do that, just uninstall v15.7.6638 and run the same installer again, that might fix any files that might of been copied over during the migration that shouldn't of been.

   The newer SmarterMail releases in v15.7 have a newer ClamAV too, that might fix errors, let alone security issues.

Good Luck!
-dave
0
Mars _ Replied
Hello Dave,

I think I will upgrade directly to the latest build 7242, hoping that all ClamAV problems will vanish.
Thank you!

Reply to Thread