Non delivery reports (NDR) are always disabled when using an outgoing gateway
Problem reported by Sébastien Riccio - 11/5/2019 at 8:05 PM
Submitted
Hello,

We currently have a lot of customers complaining they dont receive a non delivery reports when their mails are sent, for example, to a wrong external address.

It took us some time to understand what is going on:

When using a gateway, SmarterMail always use NOTIFY=NEVER on the RCPT TO: lines, so it tells the gateway to not return any DSN.

[2019.11.06] 03:38:47.263 [05482] RSP: 220 mta-gw.xxx.net ESMTP Sendmail 8.14.7/8.14.7; Wed, 6 Nov 2019 03:38:47 +0100
[2019.11.06] 03:38:47.263 [05482] CMD: EHLO mail01.xxx.com
[2019.11.06] 03:38:47.310 [05482] RSP: 250-mta-gw.xxx.net Hello mail01.xxx.com [94.x.x.138], pleased to meet you
[2019.11.06] 03:38:47.310 [05482] RSP: 250-ENHANCEDSTATUSCODES
[2019.11.06] 03:38:47.310 [05482] RSP: 250-PIPELINING
[2019.11.06] 03:38:47.310 [05482] RSP: 250-8BITMIME
[2019.11.06] 03:38:47.310 [05482] RSP: 250-SIZE
[2019.11.06] 03:38:47.310 [05482] RSP: 250-DSN
[2019.11.06] 03:38:47.310 [05482] RSP: 250-ETRN
[2019.11.06] 03:38:47.310 [05482] RSP: 250-STARTTLS
[2019.11.06] 03:38:47.310 [05482] RSP: 250-DELIVERBY
[2019.11.06] 03:38:47.310 [05482] RSP: 250 HELP
[2019.11.06] 03:38:47.310 [05482] CMD: STARTTLS
[2019.11.06] 03:38:47.341 [05482] RSP: 220 2.0.0 Ready to start TLS
[2019.11.06] 03:38:47.341 [05482] CMD: EHLO mail01.xxx.com
[2019.11.06] 03:38:47.388 [05482] RSP: 250-mta-gw.xxx.net Hello mail01.xxx.com [94.x.x.138], pleased to meet you
[2019.11.06] 03:38:47.388 [05482] RSP: 250-ENHANCEDSTATUSCODES
[2019.11.06] 03:38:47.388 [05482] RSP: 250-PIPELINING
[2019.11.06] 03:38:47.388 [05482] RSP: 250-8BITMIME
[2019.11.06] 03:38:47.388 [05482] RSP: 250-SIZE
[2019.11.06] 03:38:47.388 [05482] RSP: 250-DSN
[2019.11.06] 03:38:47.388 [05482] RSP: 250-ETRN
[2019.11.06] 03:38:47.388 [05482] RSP: 250-DELIVERBY
[2019.11.06] 03:38:47.388 [05482] RSP: 250 HELP
[2019.11.06] 03:38:47.388 [05482] CMD: MAIL FROM:<sender@localdomain.com> SIZE=1459
[2019.11.06] 03:38:47.419 [05482] RSP: 250 2.1.0 <sender@localdomain.com>... Sender ok
[2019.11.06] 03:38:47.419 [05482] CMD: RCPT TO:<wrongaddress@externaldomain.com> NOTIFY=NEVER
[2019.11.06] 03:38:47.466 [05482] RSP: 250 2.1.5 <wrongaddress@externaldomain.com>... Recipient ok
[2019.11.06] 03:38:47.466 [05482] CMD: DATA
[2019.11.06] 03:38:47.497 [05482] RSP: 354 Enter mail, end with "." on a line by itself
[2019.11.06] 03:38:47.529 [05482] RSP: 250 2.0.0 xA62clmc194285 Message accepted for delivery
[2019.11.06] 03:38:47.529 [05482] CMD: QUIT
[2019.11.06] 03:38:47.560 [05482] RSP: 221 2.0.0 mta-gw.xxx.net closing connection
[2019.11.06] 03:38:47.560 [05482] Attempt to ip, '94.x.x.151' success: 'True'
[2019.11.06] 03:38:47.560 [05482] Delivery for sender@localdomain.com to wrongaddress@externaldomain.com has completed (Delivered)
[2019.11.06] 03:38:47.560 [05482] Removed from RemoteDeliveryQueue (0 queued or processing)
[2019.11.06] 03:38:50.200 [05482] Removing Spool message: Killed: False, Failed: False, Finished: True
[2019.11.06] 03:38:50.200 [05482] Delivery finished for sender@localdomain.com at 03:38:50	[id:13066305482]

There is a toggle in SMTP Out protocol options. According to the documentation:

Disable Remote Bounces - Toggle the slider to the right to disable bounce messages for messages that fail to reach remote recipients. That means that when a SmarterMail user emails an external recipient (any user not on their domain) and their email fails to deliver, they will NOT receive a bounce message from the recipient's server. Note: This setting disables bounce messages for remote/external deliveries only. A SmarterMail user who sends an email to a user on the same domain will still receive a bounce message if that local delivery fails 

However we don't have this toggle activated, so the NOTIFY=NEVER shouldn't be added here.

I tried to flip the toggle to see if by chance it was maybe just that it is reversed, but without luck.

When disabling the gateway, the RCPT TO line doesn't contain NOTIFY=NEVER, so in this case we receive NDR.

[2019.11.06] 03:34:02.653 [05370] CMD: RCPT TO:<wrongaddress@externaldomain.com>
Also here if we enable  "Disable Remote Bounces" without using a gateway it doesn't append NOTIFY=NEVER, so I think this toggle is broken.

Does anyone else using an outgoing gateway sees the same behavior ?

We don't know what to do here as we really need to use our gateway AND have it send back NDRs.

Build 7142

Kind regards

Reply to Thread