SmarterMail 17x - Backup MX - No Such User Here when using an IP range
Problem reported by Linda Pagillo - 9/29/2019 at 12:12 AM
Submitted
Hi everyone! I have already reported this to Rod at SmarterTools, but I wanted to also post it here in case anyone else is scratching their heads over it. I set up a Backup MX on SM17x (Build 6956). I had put a few single IPs in there along with a few IP ranges. When I tested everything, I kept getting bounces stating "No Such User Here". I scratched my head because I have set up literally dozens of Backup MX servers on SM with no issues. I double and triple checked my work, checked my DNS, checked logs. Found nothing of interest. Was boggled. Called ST. Initially spoke with Ben. SM 17x on this server was like 17 or 18 versions behind. Ben advised an upgrade. I upgraded to the current build (7188). Tested again. Same bad results. Called ST again. Spoke with Rod. Tested a few things. Decided to break the IP range down into separate IPs. That fixed the problem! So I believe I found a bug. Again. Rod is aware of this and I'm sure they will fix it in a future build. I hope this helps save someone a lot of time :)

Linda Pagillo
Mail's Best Friend
Email: linda.pagillo@mailsbestfriend.com
Web: www.mailsbestfriend.com
Authorized SmarterTools Reseller
Authorized Message Sniffer Reseller
 

3 Replies

Reply to Thread
1
Richard Frank Replied
I have this issue too when the mail has to be delivered to the primary mail server but the domain is configured as incoming gateway backup mx or domain forward.
also latest update installed 7188
0
Patrick Mattson Replied
I have been scratching my head on this too, so I disable the backup server until I need it. I am afraid my customers might not get email.
1
Joe Vivona Replied
Just FYI - in build 7488 - this is still an issue.  the solution above continues to work!

Reply to Thread