Greylisting is 421 not 451?
Problem reported by Scarab - 9/17/2019 at 1:30 PM
Resolved
Not sure when this changed and/or if this is even a problem or just working as intended:

Tried searching the detailed SMTP logs for a sender that was failing Greylisting. Not that long ago I seem to recall that Greylisting used to give "451 Greylisted, please try again in 120 seconds" or whatever interval you had set for your Block Period. Now apparently, it is just giving the generic "421 Server is busy, try again later" that is given when an item is blocked by IDS or Anti-Spam Filters, making it difficult to find the ones that are failing Greylisting.

Somehow SM knows how many are Greylisted as it shows in the Reports, but I can't see from the detailed SMTP logs how to distinguish Greylisted from Blocked.

If this is a bug can it be added to the list of known issues. If it is W.A.I. can it be added as a suggestion to make Greylisting use the Greylisting server response?

7 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Hi Scarab, we're not seeing this same behavior here in our production environments. Below I've included the greylisting response we generate from mail.smartertools.com:

rsp: 451 Greylisted, please try again in 240 seconds

Is this only for IPs blocked by the IDS?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Reto Replied
I have a lot of 451 Greylisted in the SMTP logs on 7188. So looks working fine. 
0
Scarab Replied
Kyle,

I double-checked our detailed SMTP logs and found not a single 451 responses at all for three months. It would appear that Greylisting is not working at all on Incoming Gateways on build 7188, and hasn't been working for a while. Looking at the Greylisting reports on our Incoming Gateways the last time any connections were Greylisted was 4/15/2019, so apparently it has been not working since the installation of Build 7040 (replacing Build 7016 we had been using previously where Greylisting was working on Incoming Gateways).

Our settings are below:

Went through the Greylisting Bypass list to make sure that there were no Countries listed, or any broad IP Ranges added.

The \Smartermail\Service\Settings\greylist.dat has not been modified by SmarterMail since 4/15/2019 (Build 7040) on all of our Incoming Gateways. Renaming this file and restarting the Smartermail Service (on Build 7188) does not recreate this file either.
0
Kyle Kerst Replied
Employee Post
Thanks @Scarab, I'm going to spin up some testing on this now and will reach out to update you when I find out more. You may want to get a ticket submitted so we can really dig into this. Thanks!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Kyle Kerst Replied
Employee Post
I did a quick test on a brand new b7188 install and found greylisting is functioning here at least, so either the issue has since been resolved, or it is something specific to your environment. Could you open a ticket and submit your greylist.dat so I can check it out in more detail?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Scarab Replied
Marked As Resolution
Kyle,

I opened a Support Ticket and less than 10 minutes later isolated the issue. Apparently the SMTP Blocking setting "Greylist Weight Threshold" had been toggled on with the upgrade of Build 7040. We toggled this setting back off and Greylisting is working properly again.

Thanks for your help. Just being told that it is working for you is enough to find the proverbial needle in the Settings.
0
Kyle Kerst Replied
Employee Post
Thanks! Glad to hear you found this :)
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread