"HTTP Error 403.1 - Forbidden" after minor version upgrade
Problem reported by josh levine - 9/14/2019 at 12:09 AM
Submitted
Upgraded to `SmarterMail_7188.exe ` last night and now I am getting this when I try to pull up the web interface...


I tried uninstalling SM and then reinstalling and letting it create a new IIS website, but same result. 

Everything else besides the web interface seems to be working ok.

SmarterMail 15.7.6970
IIS 10.0.17763.1

This happened the last time I did a major version upgrade and I opened an emergency ticket and the tech jumped on and fixed it. I think it had something to do with handlers, but not sure.  

I'd rather not have to open an emergency ticket every time I upgrade, so any suggestions what I can do to fix this now, and what I can do to avoid it happening again in the future?

Thanks!

-josh

5 Replies

Reply to Thread
0
josh levine Replied
Ok, stumbling around I found that most of the Handler Mappings were disabled for the SmarterMail site in IIS. I right clicked on the ISAPI-dll handler and enabled `Script`, and when I hit OK all of the handlers became enabled *except* for the dll one I clicked. Hmmmm. 


The good news is that the web interface now works. The bad news is that I do not understand what was wrong, how it got wrong, and if how it got fixed. Any explanations anyone can share would be greatly appreciated. 

Thanks!

-josh
0
Gapa Smith Replied
Hi buddy, did you get this solved? Same here creating a new thread eveytime in the support jone makes me sick. Any permanent solutions?

Regards,
0
josh levine Replied
@gapa Adjusting the mapper handlings as described in the post above seems to have fixed the problem for me. 
0
Kyle Kerst Replied
Employee Post
Hello Josh/Gapa, in this scenario I recommend deleting and recreating your IIS site using our KB article that details the process: 


Doing so should alleviate any issues with the application pool, handler mappings, etc. Please also check the MRS directory under our installation folder to ensure Network Service has full control over that folder, then verify the application pool is configured to run as Network Service.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
josh levine Replied
@Kyle:

I just had this problem again upgrading to the latest build. I tried your suggestion of deleting the old site and application pool and re-adding according to the linked article. 

I also verified the correct permissions for the `MRS` folder (I had to add full access for "NETWORK SERVICE").

Unfortunately, after all that, I still got the same "403.1" error. After I went in and enable script permissions, then I got a `403.14 - The Web server is configured to not list the contents of this directory` error. Then I went and added `Default.aspx` to the default documents (it only had `Default.asp`) and then I got the following Smartmail Oops error...

System.NullReferenceException: Object reference not set to an instance of an object.
at SMWeb.Login.Page_Load(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at SMWeb.HelperClasses.CustomPage.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
Then I tried deleting the application pool and site again and doing a re-install so the SmarterMail installer could re-add the site, but back to the same `403.1` error. 

So then I went back and enabled the script permissions as I described in this thread above and then the site started working. :/

Any suggestions for what to look for or how to cure this issue once and for all so that my server does not go down every time I do a Smartermail upgrade?

Thanks!

-josh

Reply to Thread