not authorized to relay messages for external SMTP server
Problem reported by Alaa Majzoub - 9/2/2019 at 10:28 AM
Submitted
I am facing an issue with a client who is using our mail server as a secondary backup for his email.

His primary email is set on office 365, so when this client sends email from his primary email to any email in our server, our server rejects his email.
He receives this error:

Your message to alaa@***.com couldn't be delivered.

***@*** is not authorized to relay messages through the server that reported this error.


So, i guess the issue from the SMTP IN, and the setting i have is as follows:
Allow Relay:
Only Local Users

So would change this helps?

Also, i have found an option in the Domain Name options in the Email section called
Inbound Message Delivery:
External (Use MX Record) [This is my setting]

Still, i get the error.

Did anyone face such an issue?




5 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Your domain should be configured as External - Use MX Record/Use Host Address with Deliver locally if user exists enabled. Your protocol settings should be set to Nobody rather than Local Users and should require SMTP authentication for both local/external deliveries. With those settings I believe you should be good to go!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Alaa Majzoub Replied
Hello

Thank you very much for your help, I have set everything as said, the parts not clear for me are:
- External - Use MX Record/Use Host Address (I only can select either one, not both) so I selected Mx Record
- should require SMTP authentication for both local/external deliveries (There is only one option for: Enable domain's SMTP auth setting for local deliveries
The "external deliveries" are mentioned as a separate toggle: Allow relay for authenticated users. (I am afraid this will open my server to SPAM, what do you think?
The option for "Your protocol settings should be set to Nobody rather than Local Users  " has prevented all my local users to send email to the external emails, which will not work for us.

Still the issue after implementing the setting same problem


0
Kyle Kerst Replied
Employee Post
You're very welcome Alaa. The protocol settings should be configured like this: 

The Allow Relay: Nobody tells SM not to allow outbound sending unless the user has authenticated as a legitimate user first. The Allow relay for authenticated users allows users to send once they've authenticated with the SM server. The Enable domain's SMTP auth setting for local deliveries requires users to authenticate first even if they are only sending a local message (same server.)

Your domain should be configured as External - Use MX Record, but if you continue to see issues with it you can try setting it to use host address and then specify the correct server. Can you give that a try and let me know how it goes?

If this doesn't do the trick we might need to get a support ticket submitted so I can investigate further. Thanks in advance!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Alaa Majzoub Replied
Hi
This didnt do the trick.

So i guess the only chance is to whitelist the IP, what do you think?
Or do you have any other suggestion?
0
Kyle Kerst Replied
Employee Post
Alaa, yes at that point I believe you'd need to add an auth bypass for the sending server so that we don't subject it to authentication requirements. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread