After install and restart, SmartMail.exe service startup type is set to Manual. Can I change that? Why does it do that?
Problem reported by jasonj - August 19 at 1:00 PM
Resolved
After I install a newer version of SmartMail and restart our server, the startup type for the SmartMail.exe service gets set to Manual.

2 Replies

Reply to Thread
1
Scarab Replied
Marked As Resolution
I haven't experienced the same issue. I do know that the .EXE installer will remove the Service entirely, if exists, and readds it anew. If you have a Group Policy preventing Services from being added as Automatic that could be the cause of it. Regardless, from an elevated cmd prompt you should be able to use

Set-Service -Name MailService -StartupType Automatic
I know the big one for me is always forgetting to set the Recovery Options to "Restart the Service" instead of "None" for 1st, 2nd, and Subsequent Failures every time I install an update. This always gets my goat about the SmarterMail installer!
0
Kyle Kerst Replied
Employee Post
This should not happen on upgrade, but yes you can adjust the startup type by adjusting the properties of the SmarterMail service. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread