Can't upload attachments in webmail (v8.2)
Problem reported by Smarterfan - August 12 at 1:10 PM
Submitted
Hello all,

Suddenly users are unable to add attachments to outgoing emails when using the webmail on our old v8.2 SM (we are in the process of migrating them to our v16.x but it takes time).  I've taken all steps on https://portal.smartertools.com/kb/a3215/cannot-add-attachments-using-the-smartermail-web-interface.aspx and didn't have any of the issues suggested there.  As well, self diagnostics shows no issues.

Any help will be appreciated?

5 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Hello Smarterfan! I'd recommend checking the folder permissions of the SmarterMail MRS directory to ensure SmarterMail can write to the attachments/uploads directories. Things are a little different in how we access things in current versions compared to where you're at now, but if you're running this as an IIS site you'll want to make sure that identity associated with the SmarterMail application pool has full control over that MRS folder.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Smarterfan Replied
Tried your suggestion, no change.  Anything else I can try?
0
Emily Ward Replied
Employee Post
Hi Smarterfan,

You may want to try upgrading to at least the latest minor version of 8.x, which is 8.4.4359.  See if an upgrade helps.
Emily Ward
Customer Relations and Partner Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Smarterfan Replied
Ok... any significant risks associated with that move?  
2
Emily Ward Replied
Employee Post
There are no risks with doing this minor upgrade that I'm aware of.  Of course even with a minor upgrade you should do a full backup before starting.  Here's our kb article with instructions for the upgrade: Minor Upgrade of SmarterMail.
Emily Ward
Customer Relations and Partner Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread