Gmail indicates mail sent without encryption
Question asked by Vince Russo - July 9 at 8:08 AM
Answered
I am trying to figure out why when sending email to gmail accounts, they are shown as sent unencrypted.

I have an ssl certficate setup, and tests fine, but when sent to a gmail server, smartermail doesnt communicate over an ssl connection.

I also used this site to validate those findings. https://ssl-tools.net/mails

Any ideas would be appreciated.
I have setup the server using best practices using IIS Crypto as well

Thanks

6 Replies

Reply to Thread
0
Vince Russo Replied
I should also add that when receiving email from a gmail account the server receives using secure encrypted  using tls.

Received: from mail-io1-f41.google.com (mail-io1-f41.google.com [209.85.166.41]) by mail2.autohotline.com with SMTP     (version=TLS\Tls12     cipher=Aes256 bits=256);
0
Kyle Kerst Replied
Employee Post
Hello Vince, assuming you've already confirmed you have an SMTP port 25 instance set up with TLS enabled, I believe you can correct this by navigating to Settings>Protocols>SMTP Out and enable the toggle for Enable TLS if supported by the remote server. Please let me know if that works for you. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Vince Russo Replied
Hi Kyle,

Yes, I have an SMTP port 25 with TLS.
I tried that. but no Luck. I have screen shot my settings below this message.

What I notice is:
This seems to effect server to server communication.
Sending to a yahoo account or Gmail account or even a test service to check for encrypted email https://ssl-tools.net/mails
They all say not encrypted.

Also...
It seems that outlook is communicating to server via tls.
Here is a header this was sent from outlook to server.
Return-Path: <vince@edat.org>
Received: from Dev2PC (39.30.?.?.static.nwic.ca [52.129.?.?]) by mail2.autohotline.com with SMTP
    (version=TLS\Tls12
    cipher=Aes256 bits=256);
   Tue, 9 Jul 2019 20:55:26 -0400
From: "Vince" <vince@edat.org>
To: <vince@edat.org>
Subject: test





0
Kyle Kerst Replied
Employee Post
Vince, I believe we will need you to submit a support ticket on this so we can investigate further as we may need to enable some diagnostic logging to get to the bottom of this. Can you get that submitted so we can dig into this further? Thanks in advance!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Vince Russo Replied
Marked As Answer
Hi Kyle,

**Smarter Mail is working fine.

Our CISCO IOS Software had SMTP inspection turned on. This seems to cause a problem for secure email transfer.
After doing some searching online, I found others have also reported this same issue.

Turning off SMTP Inspection solves the issue



0
Kyle Kerst Replied
Employee Post
Hi Vince, thats great to hear you got to the bottom of this! I have seen issues in the past with this as well, and recommend handling all email scanning within SmarterMail itself. Have a great day!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread