Server loses bindings on changing IPv6 prefix
Problem reported by Ralf Busch - 6/15/2019 at 5:28 AM
I'm runninig SmarterMail in the free version (thanks for that!) on a full blown dual stack DSL internet connection (Deutsche Telekom) behind a router, that supports IPv6 quite good (AVM FRITZ!Box). But after a reconnection (normally after some weeks) the public IPv4 address changes as well as the IPv6 prefix /56. This is supported by AVM's dnyDNS-Service, where I can map a hostname not only to the router's addresses, but even to the server's public IPv6 address, which is really routed - no NAT for IPv6 as with IPv4. Even my mobile mostly uses IPv6, since the AAAA record exists - what I can't change
The private part of the server's address is fixed, but when the public prefix changes, the services (IMAP, SMTP) lose their bindings on IPv6, luckily the IIS dosen't, as I can bind it to all addresses. I could imagine some possible solutions:

- an option to bind the services to all addresses like IIS
- specify an IPv6 binding only by the private suffix, that dosn't change
- as a workaround a possibility to change/add a binding via CLI, which can be done by a script

Of cause switching off IPv6 would help also, but you can read everywhere: DON'T

1 Reply

Reply to Thread
Kyle Kerst Replied
Employee Post
Hello Ralf, I've submitted a feature request to our development team requesting that they review this use case and adjust as they see fit. I can't comment on how quickly we might see movement on this, but can confirm its been documented with their team. Thanks for the suggestion here! Have a great rest of your week.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278

Reply to Thread