SmarterMail 7093 - Saving mailing list options breaks the mailing list
Problem reported by Sébastien Riccio - June 10 at 1:00 AM
Submitted
Hello ST,

Some customers using SM mailing list features noticed that when changing a mailing list option (any) and saving changes, the mailing list is not usable anymore.

SmarterMail then rejects the mail with an user unknown error like if the mailing was not existing.

I tried it myself:

- Create new mailing list
- Send a mail to the list -> SUCCESS

Then, I edit an option like for example the mailinglist subject prefix and save.

- Send a mail to the list -> User unknown

 Remote Server returned '<our_sm_server.swisscenter.com #5.0.0 smtp; 550 <mymailinglist@mydomain.tld> No such user here>'

From here, no way to go back to a working mailing list except deleting it completely and re-create it (tried reload domain, full restart, etc)

PS:
The problem seems to occurs only when the mailing list was initially created from the API.

PSS:
After every restart of the service, SmarterMail webmail displays an "SmarterMail is Updating" message. But it's just a service restart, no update applied.
We need then to login as admin so it display that the update is completed. Then it seems to restarts again the service to have it running normally.
Any idea why is this happening ?


2 Replies

Reply to Thread
0
Employee Replied
Employee Post
Hello.  I just tried the same thing here with a mailing list I created via API, and did not encounter any errors.  I would submit a support ticket so we can log on and take a look into this.  Thanks!
0
Sébastien Riccio Replied
Hello Rod,

Thank you for your reply. Ticket has been submitted.

Kind regards

Reply to Thread