2
Selective Outgoing Gateways Not Working
Problem reported by Nik Walz - 5/7/2019 at 6:26 AM
Submitted
I'm trying to select different outgoing gateways per domain.  Some I want to send direct from mail server.  Some I would like to relay with a third party gateway (Amazon SES or MailChannels). I'm finding the outgoing gateway per domain has no effect on anything.  If I enable the outgoing gateway from the main settings, all email flows over this.  I only want specific domains do use this.  If I disable the main outgoing gateway settings and set individual domains to use the outgoing gateway, they send direct still.  How can I selectively allow certain domains to send email through a gateway?

SmarterMail Enterprise Edition Version: 16.3.6989
                   

3 Replies

Reply to Thread
0
Tony Scholz Replied
Employee Post
Hello Nik, 

This is a functionality that was added to the newest builds of smarterMail ( Formally called SmarterMail 17 ). To be able to chose different gateways per domain and to default to no gateway on some. 

SmarterMail 16 is at EoL and will not have anymore fixes or features released. 

Thank you

Tony Scholz
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Nik Walz Replied
So why is the option present if it does not work?
0
Kyle Kerst Replied
Employee Post
Nik, in SmarterMail v16 the outgoing gateway selection was handled on a priority basis. So you would need to add the outgoing gateways and associate them with the same priority of mail you configured the domain for that you want to be passed through it. 

In the latest release of SmarterMail, gateway selection can be configured on a per-domain basis directly, and does not require configuration of the priorities. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread