Smartermail 17/100 - Outlook Sync Delays?
Question asked by Tim DeMeza - February 28 at 8:18 AM
Unanswered
Hi All,
I updated to the latest 6996 (Note:  I said 6996, I should have said 6995) this week and honestly the conversion went really well from V15.  Everything seems to be going well.  The Admin UI confuses met, but that will clear up with time.

We have been running for a couple days on this version, the problem is I am having users tell me that they are getting emails hours and hours later.  This hasn't happened in years.  

The logs are showing fast and appropriate inbound deliveries.  30 seconds max.  Again, this is in the logs on the server.

Is there anything  with Outlook that I need to change to get it to sync better?  Most of the users are IMAP, and a couple small mailboxes ActiveSync.

I am wondering if others are seeing this reported to them as well.  

Any advice, thoughts or ideas are appreciated.  One of our companies is a payroll company.  The users are creatures of habit.  They want outlook.  

Thanks!





4 Replies

Reply to Thread
0
Paul Blank Replied
The question that comes to mind is: are the messages showing up in SM webmail faster than they are in Outlook? 

The answer to that will provide a good starting point. 

Here, I'm still sticking with v15 for now, which has been as close to trouble-free as can be, when selectively applying updates as they are shown to be OK over time.
0
Tim DeMeza Replied
So I am waiting on confirmation on this from a couple of users that agreed to test both the web interface and Outlook.  I believe, looking at the log files, that the issue is specific to syncing with Outlook.  

However, I have just been informed by a client that they are getting notified of delivery delays sending to use die to a 421 4.4.2 Connection Dropped due to Socket Error, last endpoint detected was our public IP address port 25.

Which isn't giving me a warm and fuzzy feeling.  I have opened an emergency ticket with this so we shall see.

0
Kyle Kerst Replied
Employee Post
Tim, have you applied the latest minor release and checked your SMTP logs for signs of greylisting issues? This could be the source of the email delays, and you may need to adjust your greylisting settings a bit to be more lenient. 
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Tim DeMeza Replied
So I did make a mistake here.  I was actually on 6995 even though I thought I was on 6996.  However, if the release notes for 6996 mentioned a major fix to graylisting (since lots of mail wasn't even being delivered, or simply delayed for many many hours) it sure would have raised a flag.  

Anyway, 6996 seems to have cleared my issues with mail delivery.  Although, I am unsure how to completely confirm that.  I mentioned in my ticket that I would like to have a UI for graylisting that shows email addresses and their associated wait times, time to expire, etc.   And from there, we could whitelist, blacklist, etc.  Logs are great, but sometimes I don't have time to dig that deep. 

I would also like to mention that ST support has been as good to me, if not better than ever.   I appreciate that.  That being said, if you have a problem, open a ticket.  I feel as though that is what they prioritize, and rightfully so, over the community forums.  

Reply to Thread