SM v17 - impersonation popup should not load all Domains because it is just killing browser process if you have a lot of them.
Problem reported by Webio - January 20 at 3:33 AM
Resolved
Hello,

please make loading domains as a textbox with autocomplete instead of putting all domains from SM instance in a dropdown box.

Thanks

8 Replies

Reply to Thread
1
Webio Replied
The same thing is happening in adding new activesync mailbox. Tab is frozen until dropdown will load and during this time browser CPU is going much higher than it should (test it on your end for about 5k domains installation).
0
Webio Replied
... so .. anyone from ST? This is very easy to be reproduced. Just add 5k domains with mailboxes and you will see how your browser will react when you open impersonation window or form for enabling activesync mailbox.
0
Webio Replied
Sorry for moving this topics like they where a little sticky but c'mon. This is another problem which can be investigated very quickly. Do I need to open ticket for that? Impersonation dialog or adding mailbox in Activesync mailboxes page are consuming a lot of CPU and are freezing browser in scenario where SmarterMail is handling a lot of domains since all of them are loaded somehow.
0
Kyle Kerst Replied
Employee Post
I have submitted this suggestion to our development team for resolution as we've also seen similar issues in testing here in support. Thanks for reporting this. Have a great day!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Binesh Shammunni Replied
Hello All,

Try https mode , I have installed TLS 1.2 and pointing hosting name instead of localhost the pop ups work fine . You may manually allowed both notification & pop ups then work like a charm 

Thanks
0
Webio Replied
@Binesh I think we are talking about two totally different things.
0
Binesh Shammunni Replied
@Webio I thought Smartermail 17 impersonation popup should not load all browser cause lot load issue.  Most of the browser now implement force https and I have been tested in admin part with https instead of localhost access.  The process get faster than normal localhost.  Similarly I tested with localhost and all pop ups and moving one link to another link consume more resource or delay loading time or not properly open page , Similarly active synchronization not working either and duplicate email ID displayed in adding new active synchronization 

I hope I am stick with original load issue topic  
0
Robert Emmett Replied
Employee Post
Webio, with the latest public release Build 7016, we have rewritten the APIs that are returning the domain and user information for the impersonation modal.  You should see a significant reduction in the response size and thus better performance overall use that particular modal.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread