CLAM AV
Problem reported by mark - December 19, 2018 at 11:39 AM
Submitted
I get this error in logfile:

[2018.12.19] 07:08:37.467 [13047] Unable to run Clam virus checks: System.Net.Sockets.SocketException (0x80004005): Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 192.168.70.100:3310
[2018.12.19]    bei System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
[2018.12.19]    bei System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
[2018.12.19]    bei MailService.Spam.ClamDClient.CheckStream()

9 Replies

Reply to Thread
1
echoDreamz Replied
Seems like ClamAV is not running on the IP/Port you provided.

Christopher

0
mark Replied
In SM the definations are correct. The port 3310 is open.
0
J. Dikkenberg Replied
Mark you could try a telnet from your mailserver to 192.168.70.100:3310 
That way you can fast check if it is working. Looks to me either ClamAV is not running or a firewall issue on the other end.
0
Matt Petty Replied
Employee Post
Mar kdid you install with the MSI? We noticed an issue (unreleased fix atm) with problems regarding messagesniffer and clamAV when installed through the MSI. More specifically the files required to run these tools were not included with the MSI version of the application. We will have an update out end of this week which includes a fix to this, if this is your case.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
mark Replied
Yes I have installed with the MSI. I will test it with the next update. Thanks
0
mark Replied
I installed the new build 6928. It is the same issue. I set the IP to localhost. With localhost it works. But if I enter the IP of the server it doesn't work.
0
Matt Petty Replied
Employee Post
If you are trying to run it locally, go ahead and uncheck the remote server option. You shouldn't need to provide an IP.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
mark Replied
I have unchecked the remote server option and the IP of the server. This don't work. With localhost it works.



0
echoDreamz Replied
Because the built-in clamAV that SmarterMail ships with, it is configured to listen on localhost only. There is no reason to listen on the server's IP. Keep SM configured to 127.0.0.1 and everything is fine.

Christopher

Reply to Thread