2
Enumeration Operation
Problem reported by John Marx - 12/17/2018 at 8:00 AM
Resolved
In the new v17 (latest as well as the previous release) when deleting a domain we get an error. It is no longer available in the grid (after refreshing).

This happens whether deleting from the grid (click checkbox) and choose to delete or going into the detail and clicking on delete we receive the following error message (red box lower right-hand corner).

Collection was modified; enumeration operation may not execute.

5 Replies

Reply to Thread
0
Andrea Free Replied
Employee Post
Hi John, 

I deleted a domain on Build 6925 and wasn't able to replicate that error. Could you please update to see if it resolves the issue? 

If it doesn't, your license has active Maintenance and Support which allows you to receive free, unlimited technical support for issues like this. I went ahead and started a support ticket to address this issue. You should receive the Support Department autoresponder shortly. You can reply via email and access your ticket online by logging in here: https://www.smartertools.com/account/#/support. If you could, please also submit a Remote Server Access Agreement that will allow the support agent to take a look at what you're seeing. 

Thank you,

Andrea Free
SmarterTools Inc.
877-357-6278

www.smartertools.com

0
Employee Replied
Employee Post
John, I'm reaching out to verify whether or not this issue is still occurring for you.
0
John Marx Replied
I didn't think of checking that as it wasn't on the list of items that I saw. I just removed one and the error did not happen so it looks like it's cleaned up and fixed. Great job. :) 
0
Nikola Kuzmanovic Replied
Hi, I got this error - Collection was modified; enumeration operation may not execute - on Build 6928 while deleting a domain. It throws the error but the domain is not shown in the Domains menu anymore. Still, the references and the domain folder is not deleted. When I restart the service it is visible under Domains again.
I updated to the build 6956 but the issue persists. Is there a fix to it?
0
Employee Replied
Employee Post
Nikola, I would suggest that you open a support ticket.

Reply to Thread