Mail forward no longer working (API)
Problem reported by Jade D - December 12, 2018 at 7:45 AM
Resolved
When setting a forward via API / Control Panel the forwarding email address is sent through to SM, how ever it seems that "Enable automatic forwarding" needs to be enabled on the users mailbox via smartermail in order for forwarding to work.
IE the old api is not setting Enable automatic forwarding to on.

3 Replies

Reply to Thread
0
Andrea Rogers Replied
Employee Post
Hi Jade, 

Thanks for reaching out. Can you please clarify the API call you're using? 

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

0
Robert Emmett Replied
Employee Post
Jade, I'm assuming that you are referring to the legacy SOAP API calls?  If so, we should be able to add a domain setting parameter for the "Enable Automatic Forwarding" setting to allow this setting to be changed.  Can you verify that is the API to which you are referring?
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Robert Emmett Replied
Employee Post Marked As Resolution
Jade, we have changed the svcDomainAdmin and svcUserAdmin legacy APIs to handle the new "Enable Automatic Forwarding" setting.  In the svcDomainAdmin methods to get and set domain settings, we have added the keyword variable "enableautomaticforwarding".  In the svcUserAdmin UpdateuserFowardingInfo2 method setting a forwarding address will enable the domain setting.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread