Failed all attempts to connect to recipients mail server
Question asked by Daniel Comp - December 3 at 8:44 PM
Unanswered
Long story short.

SmarterMail Version - 15.5.6222
An email address gets hijacked for spam
We delete the email address
Google blocks the mail server IP
We clear all mail server checks, have spf, dkim, etc.
6 weeks later, Google still hasn't released the IP
We move the mail server to another public IP
The new IP is a higher number, (not lower)
We now have the error: 

"Failed all attempts to connect to recipients mail server"

Received: from mail.in8dna.net (UnknownHost [174.143.58.140]) by mail.in8dna.net with SMTP;
   Mon, 3 Dec 2018 15:14:53 -0600
Received: from mail.in8dna.net (UnknownHost [174.143.58.140]) by mail.in8dna.net with SMTP;
   Mon, 3 Dec 2018 15:14:20 -0600

174.143.58.140 IS NOT the new Smartermail IP.
174.143.58.142 is in every setting I can find.

DNS is set to default to the Rackspace DNS

Is it the lower IP number due to MS Windows defaults?
Is there a way to fix the issue?
Do I have to return to the lower number? (which is blocked)


4 Replies

Reply to Thread
0
Paul Blank Replied
If the Windows server has a lower IP address, SM v15 will quite possibly default to this - I have seen this problem and commented on it elsewhere in the forum. You should use the lowest IP address on your server that's in that IP block for SM, which may mean re-addressing the server itself if the lowest address has been blocked.
 
You can also use a firewall/NAT router to change the public address, so that the server's LAN address stays the same, but in your case that will require re-addressing the server to a LAN address, with the public address(es) configured on the router. This is what I do.
 
FYI my router/firewall is a recent model Sonicwall.


0
Daniel Comp Replied
Thanks for the direction. We've changed the lower IP number on the NIC. I've checked the SM DNS settings and all the configurations, and I'm now getting a slightly different error?

Failed Recipient: recipentname@gmail.com
Reason: Failed all attempts to connect to recipients mail server

   -- The header and top 20 lines of the message follows --

Received: from DanielWin10 (71-95-111-10.dhcp.knwc.wa.charter.com [71.95.111.10]) by mail.in8dna.net with SMTP;

Ideas?
0
Jade D Replied
Check your smartemail domain configuration files for the old IP.
Edit the file, update the old IP with the new and restart the service.

Have you updated smartermail's outbound IP?
0
Daniel Comp Replied
What a relief. After 6 weeks of GMAIL challenges, we're running. I believe the final issue was the DNS settings. When SM DNA was set to use the NIC, or aimed at the internal Rackspace DNS IPs, it failed to deliver to GMAIL, when SM was set to 8.8.8.8 and 8.8.4.4 (Google) we get delivery.

Thanks for the assistance. Much appreciated.

Reply to Thread