Newbie: SM 15.* Setup: Win7P, IIS 7.5, (Business FiOS, fixed IP, Name.com). Send but can't Receive
Question asked by Clayton Vernon - November 4 at 5:03 AM
Unanswered
I am interested (again) in getting SM up and running, the free version, hosting a public website from one of the computers on my home network. I have Small Business FiOS with a fixed IP address. The computer is running Win7 Pro SP1 and the IIS version is 7.5.7600.x.

Here are my DNS records at name.com, where my domain "aquivia.com" is registered:


On my router, the following TCP ports are forwarded to the computer that is to be the mailserver:

21, 25, 80, 110, 143,  389, 443, 465, 587, 993, 995, 5222

On the computer to be the mailserver, it is set to be on the Home network and the firewall permits both Home and Public thru access to both HTTP and HTTPS.

I purchased and installed via IIS (seemingly successfully) an SSL wildcard certificate for :*.aquivia.com"

I installed the latest 15.* SM via the executable, and disabled the self-webserver.

In IIS, I followed the instructions and created an Application Pool and Site:


The AppPools are as follows:


Network Service was selected:


The SM site looks like this:


The ISAPI filters are as:


.NET version 4.7.2 is installed on the mailserver.

In a browser (Chrome) opened on the webserver, an admin and user account were created for the domain. These can be logged into and out of, fine. As the user, I can send emails to my work domain and to my personal gmail account, and these can be seen by me logged into these accounts. Work does not flag the email as spam, and Gmail tells me the email was not encrypted. My full name came thru properly.

But, when I reply to these, nothing appears in my SM inbox.

Here is nslookup from the mailserver, the output is the same from another of my home computers:


I enabled telnet for the mailserver, and it cannot connect to port 25.


I have a feeling this is something very basic I am missing here. 

Ultimately, I need to get secure email and ftp up and running, and prefer to not require the user to know alternate port numbers, rather only "mail.aquivia.com" as the mailserver and "ftp.aquivia.com" as the ftp server.

2 Replies

Reply to Thread
0
Linda Pagillo Replied
Hi Clayton. I did a test on aquivia.com and I can see that port 25 is closed and you also have an issue with your SPF record. You may want to check your firewall. If you have any questions, please ask and I will be happy to help. Thanks.
Linda Pagillo
Mail's Best Friend
Email: linda.pagillo@mailsbestfriend.com
Web: www.mailsbestfriend.com
Authorized SmarterTools Reseller
Authorized Message Sniffer Reseller
 
0
Richard Frank Replied
Also this is not right syntax for telnet command



It should be :\>telnet <hostname| IP number> <port number>

for home computers using the public name you should set up an internal DNS service for mail.aquivia.com with the internal IP number

mostly on home routers you cannoet connect to the public IP number (WAN side) of your router to reach a client on the LAN. You need to configure a loopback NAT or also called hairpinning.

Reply to Thread