Some base64 subject and other header decoding is bad in webmail
Problem reported by Matthew Bramble - October 12 at 11:44 AM
Submitted
Some base64 encoding of Subjects, From and To fields, and possibly others that display in webmail summary lists and actual email display are not functioning properly.  The encoding looks to be proper, and I have confirmed that at least Thunderbird has no problems with the encoding while webmail does.  Webmail is inserting a ";" where line breaks in the encoding appear, but these should not be characters at all.

This is an example of the encoding:

Subject: =?ISO-8859-1?B?Y2xvc2Ugcw==?=
    =?ISO-8859-1?B?dGF0ZW1lbnQg?=
    =?ISO-8859-1?B?Zm9yIDE5IEVM?=
    =?ISO-8859-1?B?SVpBQkVUSCBM?=
    =?ISO-8859-1?B?TiAxMC8xMi8y?=
    =?ISO-8859-1?B?MDE4IDEyOjIz?=
To: "=?ISO-8859-1?B?VGFtYXJhIHZhbGVu?=
    =?ISO-8859-1?B?dGluZQ==?="
    <tvalentine@example.com>

This is what it displays:

3 Replies

Reply to Thread
0
Scarab Replied
Matthew,

Are you running 16.3.6855 by chance? It sounds to me like a related issue to the "Fixed: Certain Base64 encoded message parts are not getting RFC line breaks causing 550 Line too long errors".

Fix one thing and inadvertently break another...if you are on 16.3.6855 you might want to open a Support Ticket for this one as it is clearly a bug/unintended feature.

If you aren't on 16.3.6855 try upgrading to see if it resolves the issue.
0
Matthew Bramble Replied
Good catch.  The most recent patch was planned for an install tonight.  I'll check on this issue after I do that, but it looks very promising.
0
Andrea Rogers Replied
Employee Post
Hi Matthew,

Have you encountered this issue while running SmarterMail 16.3.6855? 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

Reply to Thread