Logging out from SmarterMail 16.3.6841 leads to an error instead to the login page
Problem reported by Stefan Mössner - September 24 at 9:49 PM
Resolved
Hi all,

today I updated SmarterMail to 16.3.6841. When logging out from SmarterMail there's an error page instead of the login page: The URL shown after loging out is http://:9998/interface/ and I see the following error page:

Serverfehler

403 - Verboten: Zugriff verweigert.

Die angegebenen Anmeldeinformationen berechtigen Sie nicht, dieses Verzeichnis oder diese Seite anzuzeigen.

Sorry for pasting the error page in German but I don't have the English language setting.

Kind Regards

10 Replies

Reply to Thread
0
Stefan Mössner Replied
Hi all,

this issue is happening with Internet Explorer and Microsoft Edge on Windows 10. With Microsoft Edge for Android the issue doesn't happen.

Yesterday, I updated to 16.3.6843 but there's no change. With the releases before 16.3.6841 there was no issue like this.

Kind Regards
0
Robert Emmett Replied
Employee Post
Stefan, can you make sure that you have 16.3.6843.32768 as the download file.  There was an issue discovered yesterday with the previous version.  It should be fixed if you re-download the file.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Stefan Mössner Replied
Robert,

yes I downloaded the setup file 16.3.6843.32768 yesterday at 20:15 CEST. And as you can see in this thread, this issue began with build 16.3.6841.

Kind Regards
0
Gary Steiner Replied
Today I upgraded to 16.3.6843 from 16.3.6821 by using 16.3.6843.32768 as the install file.  I am now experiencing the same error.  Though I'm experiencing it with a site with https, if that's any difference.

403 - Forbidden: Access is denied.

 

You do not have permission to view this directory or page using the credentials that you supplied.



0
Scarab Replied
We are experiencing the same thing on v16.3.6841 (haven't updated to 16.3.6843 yet). 

We were able to resolve it by setting a Logout URL for every domain (previously they had all been unset). You can set one by going to MANAGE > [...] > DOMAIN DEFAULTS and enter a Logout URL and [SAVE]. You can then use the [PROPAGATE] button to commit that Logout URL to all domains. This fixed the problem for us.
0
Stefan Mössner Replied
Hello Scarab,

that's interesting. And which URL did you set?

Kind Regards
0
Scarab Replied
Stefan,

We just did https://ourprimarydomain.tld. If you don't have SM Enterprise version you'd do http://yourprimarydomain.tld. We did not define a specific page, just the raw domain so that SmarterMail can do it's redirect magic on it's own.

It's just really strange that it always worked without a Logout URL set before and then as of 6841 it stopped working and required one to be set or you would get the 403 - Forbidden response.
0
Gary Steiner Replied
This error seems to show up intermittently.  Customers will go through a whole day and not experience it, then the next day it comes back in full force.

As stated previously, build 16.3.6843.32768 does not fix the problem.
1
Andrea Rogers Replied
Employee Post
Hi all,

The fix for this issue is coming in the next minor release for SmarterMail 16.x. Please stay tuned. 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
Stefan Mössner Replied
Marked As Resolution
Hi Andrea,

I can confirm that with SmarterMail 16.3.6855 the logout is working again as expected. There's no error page any more when logging out from the webmail UI.

Thank you very much for fixing this issue.

Kind Regards

Reply to Thread