SPF Record SMTP Authentication Relay SM15, SM16, SM17
Question asked by digital.iway - September 11 at 5:10 AM
Unanswered
I have SM V15.7.6821 and a client that needs to send mail for order using shopify.  Now I added the correct SPF record, but SM does not accept the SPF record and bounces mail with "550 Authentication is required for relay"

My questions: Can I correct this in SM 15 and has anyone done this with shopify?  if not does SM16 work with this and will it honor the SPF record?  If not will SM17 Work with this and will it honor the SPF record?


I know I can use SMTP authentication bypass, but shopify will not tell me the ip range of their smtp servers and they keep saying just use SPF and whitlist the mail server host name.  Also I think that SMTP authentication bypass is a security risk, but I need a temporary solution before I upgrade to SM17.

I really need some options to get this working and minimize security risk knowing that there will be some.


SETTINGS:
my SMTP in "Allow Relay" is set to - Nobody
Allow relay for authenticated users is - ON
Enable domain's SMTP auth setting for local deliveries - ON
Every domain - Require SMTP Authentication - ON

I am running DECLUDE and message sniffer both of which have shopify servers white-listed.
Security > trusted senders (does not work in this case)


I found an ongoing thread below but wanted to start a new one building on the SM versions and what works:

1 Reply

Reply to Thread
0
Emmet McGovern Replied
Shopify needs to be pressured on this. I regularly request that they switch to using the shop domain in the replyto instead of the from like they currently do.  It's doubtful the change will happen from SmarterMail.  They haven't considered it for 16 or 17.  We just recommend Gmail or 365 to our Shopify clients now.  

Reply to Thread