Logging in as one domain aliases causes others to disappear
Problem reported by Adam Lewis - August 22 at 7:02 AM
Not A Problem
We have many domain aliases, and one corporate domain. The corporate domain is the "real domain" setup in Smartermail, and all of our brands are aliases underneath. Some of our employees would like to have their "default" email be an alias and not the corporate domain because they do all communicating as a specific brand. We tried to have them log in as user@domainalias.com to see if that worked, and it did, except now they cannot send emails out as any of our other domain aliases, only as SMTP accounts they've setup.
 
Here is a video to show exactly what I mean - 
 

4 Replies

Reply to Thread
1
Paul Blank Replied
It's possible that this is by design, and if so, if there's a way to shut that behavior off.
 
I'm certainly curious to see ST's response to this.
 
0
Andrea Rogers Replied
Employee Post
Hi Adam,
 
This is the expected behavior when logging using a domain alias. The other aliases won't be available since the user has specified an alias during login. An alternative solution: Have the user log in with their corporate domain. In Account Settings, they can set the "Default From Address" to the domain alias. All replies and new messages will be sent from that domain alias address, and they can manually change the Send From dropdown as needed.
 
Another useful setting they could enable is "Use To: address to replies".  When enabled, replying to a message via webmail will use that email's To: field as the Send From address of the reply, regardless of whether the message was sent to their SmarterMail email address or a domain alias, email alias, SMTP account, disposable address or plus address. For example, if an email is sent to the user's corporate domain, their reply would come from that same domain address. This setting does not prevent the user from manually changing the Send From address when composing a message, so they can adjust the From address as needed. 
 
I hope this helps! 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
Adam Lewis Replied
Thanks Andrea. Unfortunately, that setting doesn't work correctly and never has for us. Watch this video to see what happens. Essentially, it sets the "from" address to "domainalias@realdomain.com" but still sends out as the real domain. Which probably good since domainalias@realdomain.com isn't a valid email.

https://www.dropbox.com/s/w7s1sbr73cxge9d/SendFromDoesntWork.mp4
0
Andrea Rogers Replied
Employee Post
Adam, thank you for bringing this to our attention. This issue has been resolved and will be in the next release of SmarterMail. Things are now working as expected with the 'Default From Address' and 'Use To: Address for Replies' settings, as I described above.

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

Reply to Thread