Mails won't be sent via relay - The object reference was not set to an object instance.
Problem reported by Stefan Mössner - July 20 at 11:55 AM
Resolved
Hello all,
 
since a few days there are problems with sending mails. Today I took a look to the delivery log file and saw this error:
 
20:43:48 [66003] Delivery started for xxx (via xxx) at 20:43:48
20:43:51 [66003] Added to SpamCheckQueue (1 queued; 0/30 processing)
20:43:51 [66003] Starting Spam Checks.
20:43:51 [66003] Skipping spam checks: User authenticated
20:43:51 [66003] Spam Checks completed.
20:43:51 [66003] Removed from SpamCheckQueue (0 queued or processing)
20:43:54 [66003] Added to RemoteDeliveryQueue (1 queued; 0/50 processing)
20:43:54 [66003] Sending remote mail for xxx
20:43:54 [66003] Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
   bei RelayServer.RemoteDeliverySession.#GKb(List`1 #L6i, Domain #f8m)
20:43:54 [66003] Removed from RemoteDeliveryQueue (0 queued or processing)
 
I'm using my free mail account as relay for sending mails via SmarterMail to external mail addresses. In the past I didn't had such issues with sending mails this way.
 
I updated SmarterMail to the newest release of 16.x which came out today but this doesn't help.
 
I tested the SMTP connection to my free mail account and SmarterMail says that the connection can be established successfully.
 
Any ideas?
 
Kind Regards
 
PS: I'm not able to open a support ticket because I'm using the free version as home user.

17 Replies

Reply to Thread
0
Stefan Mössner Replied
Hello all,
 
does nobody have an idea? I restarted my Windows machine where SmarterMail is installed but this doesn't solve the issue.
 
There's no problem with receiving mails by retrieving them from my free mail provider. But I still can't send out mails by relaying them. And the SMTP connection test is successful. For me it looks like there's something wrong with the SmarterMail installation.
 
And there are no error messages sent to the domain administrator or to the primary administrator.
 
Kind Regards
0
Stefan Mössner Replied
Hello all,
 
today I updated to the newest release of SmarterMail 16.x. After uninstalling the previous release of 16.x I rebooted my system and then installed SmarterMail again. But the issue of not sending mails via relay is still there.
 
It's an issue with SmarterMail because a test with a second free mail provider is unsuccessful, too.
 
Kind Regards
0
Robert Emmett Replied
Employee Post
Stefan, can you enable debug logging 22334?  Please provide the {date}-debugLog-22334.log file when the issue occurs again.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
CLEBER SAAD Replied
Hello Robert. Where enable this logginf 22334?
0
echoDreamz Replied
Enable under Troubleshooting => Under Log Files => Debug Log IDs. Add it here and click save.

Christopher

0
Stefan Mössner Replied
Hello all,
 
how to enable this debug logging? I can't find "Troubleshooting => Log Files => Debug Log IDs". In which user context is this option configurable? Is it the global admin or the domain admin or as user?
 
Kind Regards
0
CLEBER SAAD Replied
Stefan,
It's only implemented in the version 16.3.6530 +
0
Robert Emmett Replied
Employee Post
Sys admin > Manage tab > Troubleshooting (very bottom option) > Options tab > Log Files card > Debug Log IDs.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Stefan Mössner Replied
Hello all,
 
OK, now I found the place for this option:
 
 
I hope this setting is correct. I will reproduce the issue today and will upload the log file if there is one.
 
Kind Regards
0
Stefan Mössner Replied
Because of sensible data in this debug log file I don't want to upload it to this thread. Instead I sent it to SmarterTools directly.
1
Stefan Mössner Replied
Hello all,
 
with SmarterMail 16.3.6789 I'm now able to send out mails again via the relay of my free mail provider. But this release isn't available any more. I don't want to revert back because then I can't send out my mails. What's the reason for taking SmarterMail 16.3.6789 away from download? Are there any security issues with this release?
 
Kind Regards
0
Paul Blank Replied
I think you meant "sensitive" data.
2
Robert Emmett Replied
Employee Post
Stefan, the reason it was pulled was because of a issue with hyperlinks within messages and also potential mal-formatting of the To and Cc fields in certain clients.  The following custom build has the fixes affecting your server still in place with the errant code reverted.
 
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Stefan Mössner Replied
Hi Robert,

thank you for this custom release. I can confirm that after updating to 16.3.6790.18503 the mails will be send by relaying via my free mail provider.

Can you please explain what was the root cause for my issue with sending mails?

Kind Regards
0
Stefan Mössner Replied
Yes, I meant sensitive data. Thank you for correcting.
0
Stratos Geroulis Replied
I can confirm I had the same problem after updating, see thread here:
https://portal.smartertools.com/community/a90983/smtp-account-on-16_3_6782-not-working.aspx#103330

This custom build solved my problem as well...
0
Stefan Mössner Replied
Hello all,
 
with SmarterMail 16.3.6795 the issue is solved, too.
 
Kind Regards

Reply to Thread