CLAMD.exe Faulting left and right
Question asked by John Marx - June 11 at 8:25 PM
Answered
Every new email seems to be causing the following in my Windows Event log. Anyone else experiencing this or know of a fix? Server is Windows Server 2016 and never an issue with the previous versions.
 
Faulting application name: clamd.exe, version: 0.100.0.0, time stamp: 0x5ac41fd0
Faulting module name: VCRUNTIME140.dll, version: 6.3.9600.18895, time stamp: 0x5a4b127e
Exception code: 0xc0000135
Fault offset: 0x0009d4e2
Faulting process id: 0xfe0
Faulting application start time: 0x01d401fc40e575e3
Faulting application path: C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam\bin\clamd.exe
Faulting module path: VCRUNTIME140.dll
Report Id: 7e946368-6def-11e8-80f8-000d3a901e03
Faulting package full name: 
Faulting package-relative application ID: 

7 Replies

Reply to Thread
0
Seeing same
0
Started happening with us on 15.7.6726. Tried a reinstall didn't help. Seems to be due to the installer not bundling the correct redistributable.
0
Logging stopped at C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam\log as soon as the new version was installed. 
0
Same except the VCRUNTIME140.DDL File is missing.  Windows Server 2012R2 with SM 15.7.6726
0
Right. If we try to run clamd.exe at (C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam\bin) then we get error: "The program can't start because VCRUNTIME140.dll is missing from your computer. Try reinstalling the program to fix this problem."
 
My understanding is that the SM installer should having including this DLL in a Microsoft Visual C++ Redistributable.
1
Von-Austin See Replied
Employee Post
Greetings,
 
We have identified the issue with the latest 15.7 installer and do have a fix available. This fix can be obtained from here: https://www.smartertools.com/downloads/SmarterMail/CustomBuilds/15.7.6737.29006/SmarterMail15_Setup.exe
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
I am having the same problem with version 16.3.6733
This occurred when we upgraded to clamav 0.99 to 100.0

Reply to Thread