RBL entry will not allow you to save it without specifying Required Lookup Values
Problem reported by David Sovereen - March 12, 2018 at 8:58 PM
Resolved
We are using Webmail Enterprise Edition Version: 16.3.6628, and if you try to save an RBL entry that does not have a Required Lookup Values (even with this option turned off) it will not allow you to save the entry. The Save button is enabled, but clicking it does nothing. In order to save, you need to enable the Required Lookup Values and enter a value, and then disable the Required Lookup Values option. It seems as if even with the option disabled it is still doing server side validation of this field and returns the response -
 
{"message":"LookupResultsIndicatingSpam must be IP addresses"}

3 Replies

Reply to Thread
0
Andrea Rogers Replied
Employee Post
Thanks for the report, David. I'm only seeing this issue when I enable the Required Lookup Value field, remove the default IP address, and disable the field again. Is this what you're seeing as well? I'll report this to be resolved - just want to make sure we're experiencing the same thing. 

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

0
David Sovereen Replied
Andrea, yes, that is exactly the scenario that this occurs in. We were troubleshooting a potential issue with spam filtering, and figured this was a bug since turning off the Required Lookup Value removes the asterisk indicating that it was required. Because of this, we had to take a screen shot of the settings of each RBL, and remove them all one-by-one just to re-add them later.

Thanks for the reply,
Jason L.
0
Robert Emmett Replied
Employee Post Marked As Resolution
This issue was resolved with the 16.3.6893 (Nov 15, 2018) release.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread