CLAM Errors in server event log SM15
Problem reported by digital.iway - February 21 at 6:04 AM
Resolved
I am running SM version 15.7.6614 on a windows 2012 server
 
I am getting the following An unhandled exception has occurred in the server event logs 15 times a day minimum and noticing an increase in the amount of spam the server it letting come through.  Any ideas to what might be causing this or does anyone have this similar issue?
 
Faulting application name: clamd.exe, version: 0.99.3.0, time stamp: 0x5a68ef42
Faulting module name: MSVCR100.dll, version: 6.3.9600.18821, time stamp: 0x59ba86db
Exception code: 0xc0000135
Fault offset: 0x00000000000ece70
Faulting process id: 0x574
Faulting application start time: 0x01d3aa9ad95598f6
Faulting application path: C:\Program Files (x86)\SmarterTools\SmarterMail\Service\Clam\bin64\clamd.exe
Faulting module path: MSVCR100.dll
Report Id: 1707ffd5-168e-11e8-8115-5654a1c5d44b
Faulting package full name:
Faulting package-relative application ID:
 
 
 3005
   An unhandled exception has occurred.
   2/20/2018 5:37:43 PM
   2/20/2018 10:37:43 PM
   99003c733b3a4262bbb7be3aaab83398
   11
   10
   0
   /LM/W3SVC/2/ROOT-1-131636395619564546
   Full
   /
   C:\Program Files (x86)\SmarterTools\SmarterMail\MRS\
   VM3
    
   3084
   w3wp.exe
   NT AUTHORITY\NETWORK SERVICE
   NullReferenceException
   Object reference not set to an instance of an object. at SMWeb.Main.frmMessages.SetupMenu() at SMWeb.Main.frmMessages.frmMessages_Load(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at SMWeb.HelperClasses.CustomPage.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
   http://mail.CLIENT-DOMAIN-WAS-HERE.COM/Main/frmMessages.aspx?user=USERNAME-WAS-HERE&folder=junk e-mail&mapped=false&leftnav=true
   /Main/frmMessages.aspx
   IP-ADDRESS-WAS-HERE
    
   False
    
   NT AUTHORITY\NETWORK SERVICE
   18
   NT AUTHORITY\NETWORK SERVICE
   False
   at SMWeb.Main.frmMessages.SetupMenu() at SMWeb.Main.frmMessages.frmMessages_Load(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at SMWeb.HelperClasses.CustomPage.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)  
 
 
 

7 Replies

Reply to Thread
0
Linda Pagillo Replied
Hi Mike. Make sure to install the 64-bit C++ package on your server. Some users have reported also needing to install the 32-bit C++ 2010 as well. You can go ahead and install them both as it will not hurt anything…
 
Here are the links to the packages…
 
 
Please let me know if that does not help. Thanks.
Linda Pagillo
Mail's Best Friend
Email: linda.pagillo@mailsbestfriend.com
Web: www.mailsbestfriend.com
Authorized SmarterTools Reseller
Authorized Message Sniffer Reseller
 
0
digital.iway Replied
Thank you Linda I appreciate that.  When I reviewed the links I see that the system requirements do not state windows server 2012 which I have.  would there be a later version recommended like this link? https://www.microsoft.com/en-us/download/details.aspx?id=52685
0
Linda Pagillo Replied
You're welcome! I believe that ClamAV requires the 2010++ even on a Windows 2012 server. It won't hurt to install those packages on 2012.
Linda Pagillo
Mail's Best Friend
Email: linda.pagillo@mailsbestfriend.com
Web: www.mailsbestfriend.com
Authorized SmarterTools Reseller
Authorized Message Sniffer Reseller
 
0
David Fisher Replied
This link lists the updated system requirements : https://support.microsoft.com/en-us/help/2661358/minimum-service-pack-levels-for-microsoft-vc-redistributable-packages
0
Linda Pagillo Replied
Thanks David. I see that the 2010++ packages are supported on 2012 server.
Linda Pagillo
Mail's Best Friend
Email: linda.pagillo@mailsbestfriend.com
Web: www.mailsbestfriend.com
Authorized SmarterTools Reseller
Authorized Message Sniffer Reseller
 
0
digital.iway Replied
just an FYI I tested the 2015 Redistributable both 32 and 64 installed at the same time and clam will not function and throws an error of MSVCR100.dll not found. Also when I installed the 2010 - 64 I needed to wait for windows update to pickup an update pending to that 64 version because it was also throwing errors until updated and rebooted. I am not sure why 2015 does not function since it would seem the new later version would be improved, but maybe clamav is behind in development. Anyway it seems functional now.
0
Linda Pagillo Replied
Thanks for the additional info Mike. I'm glad that it is now working for you. I had the same issue with a customer yesterday who is running a 2016 server and installing the 2010 packages resolved his issue as well.
Linda Pagillo
Mail's Best Friend
Email: linda.pagillo@mailsbestfriend.com
Web: www.mailsbestfriend.com
Authorized SmarterTools Reseller
Authorized Message Sniffer Reseller
 

Reply to Thread