Firefox - Cannot upload attachments latest SmarterMail
Problem reported by Bryan Zimmerman - December 22, 2017 at 11:59 AM
Submitted
Thank you for your continued improvements to SmarterMail 16.x.
 
The issue of not being able to add attachments to new messages in SmarterMail using Firefox V56.0.2 persists.  The attachments always sit at a green bar and never complete.  A screen shot is attached.

13 Replies

Reply to Thread
0
Matthew Kides Replied
Employee Post
Hello,
 
Does this happen every time you try to upload an attachment? I am currently unable to reproduce the issue on Firefox 57.0.2.
 
Regards,
Matthew Kides
Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bryan Zimmerman Replied
Matthew,

Thank you for taking a look. Yes this happens every time. I am using 56.0.2 version of Firefox.

Sincerely,
Brryan Z
0
Matthew Kides Replied
Employee Post
Does it only do this on Firefox or does it also fail on other browsers?
Matthew Kides
Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bryan Zimmerman Replied
Google Chrome works fine. Haven't tried IE.
0
Matthew Kides Replied
Employee Post
I was able to downgrade my Firefox to 56.0.2 and am still unable to reproduce this against our server. If you open the dev tools with f12 and go to the network tab then try to upload a file does the upload call fail?
Matthew Kides
Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bryan Zimmerman Replied
If I use firefox, I get an immediate failure if I drag the attachement to the new message window. If I use the clip I get the stuck at green. The httpbind's are short in duration.

If I use chrome, I can drag or attach and I see two httpbind's of 8 to 9 seconds after the successfull attaching of file.
0
Matthew Kides Replied
Employee Post
The httpbind calls are normal and unrelated to attachments. There should be a POST call with the name upload in the list. Is that returning with a 200?
Matthew Kides
Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bryan Zimmerman Replied
In chrome the post calls return with status 200(OK). In firefox the post calls do not return with a status.
0
Bryan Zimmerman Replied
Is there some kind of trace output I can provide you with to help troubleshoot?
0
Matthew Kides Replied
Employee Post
Try opening firefox by shift-clicking on the icon to run it in safe mode which will disable all extensions. Then try running a private tab and see if it still fails to upload.
Matthew Kides
Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bryan Zimmerman Replied
With firefox in safe mode and all extensions disabled the drag and drop seems to function correctly; however the attach paper clip operation still hangs with green bar never completing.
0
Matthew Kides Replied
Employee Post
If you would feel comfortable doing so would you be able to create a test account for me on your server and private message me credentials for it?
Matthew Kides
Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Bryan Zimmerman Replied
Created for testing

Reply to Thread