Domain Keys become invalid after upgrades
Problem reported by Barbara Renowden - December 7, 2017 at 4:04 PM
Resolved
Recently I have noticed that domain keys suddenly no longer work on some domains after updating to the latest version.  I have had this happen on several of the recent updates.  Nothing else really changes except updating to the latest version of Smarter Mail.  I updated on Monday morning this week and then started getting complaints from clients that their mail was bouncing when sending.  Prior to this last update, they were able to send mail to the same client without issues.  When I checked the logs found out the domain key didn't match up.  So had to reissue another.  Started digging on other domains and found the same issue on several other domains that we host.  I have updated those but hope I do not have to do this everytime we update the software.  That gets to be a lot of work. Anyone else having the same issues? 

Barbara Renowden President / Co-Founder Centric Web, Inc. https://www.centricweb.com

13 Replies

Reply to Thread
0
Ionel Aurelian Rau Replied
I can confirm that lately SmarterMail apparently randomly stops signing outgoing mail with DKIM. In the domain`s setting we have "DKIM is running on this domain and signing outgoing mail.", but when testing (http://dkimvalidator.com/ or check-auth@verifier.port25.com), the messages are not signed. This started occurring in the last 2 weeks and the only way we`ve got it to work was to disable and re-enable DKIM, which of course it means you need to re-do the whole process with adding the DNS record.

However, we were not able to corelate it directly to updating. We test after each update and right after Version 16.3.6544 messages were being signed with DKIM (we installed this version on 2nd of Dec.). However, since yesterday emails are not longer signed with DKIM, although the server is lying about it :)

@SmarterTools: can you acknowledge if it`s a bug and that it will be fixed soon?
1
Robert Emmett Replied
Employee Post
We have another report of this happening. We are currently setting up a test environment to verify the issue. We will update this post after confirmation.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Ionel Aurelian Rau Replied
hopefully we will be able to update and fix this over the week-end..
0
Barbara Renowden Replied
I certainly hope so as customers are complaining AGAIN.

Barbara Renowden President / Co-Founder Centric Web, Inc. https://www.centricweb.com

0
Robert Emmett Replied
Employee Post
Barbara, are you having to reenter the DKIM certificate values every time you upgrade?
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Barbara Renowden Replied
Only on some of the domains but I have to check every domain to see what is working and what isn't. That is a pain.

Barbara Renowden President / Co-Founder Centric Web, Inc. https://www.centricweb.com

0
Tim Uzzanti Replied
Employee Post
We were unable to duplicate.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Ionel Aurelian Rau Replied
Just updated to v16.3.6551 and although in the domain`s settings I have the "DKIM is running on this domain and signing outgoing mail." text, there actually is no DKIM signature on the outgoing mails. This in itself it should be a stand-alone bug.

I`ll re-setup DKIM and see if it will stop working again at random or at a future update.
0
Barbara Renowden Replied
Over the weekend I had to redo 15 domain keys. That had previously been set up but were now failing.

Barbara Renowden President / Co-Founder Centric Web, Inc. https://www.centricweb.com

0
Tim Uzzanti Replied
Employee Post
Can you give more details? Was it after an upgrade? Were you running SM 16 and all was good and then all of the sudden you had an issue?
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Matthew Sine Replied
Ditto. Another thing that is happening on our larger SM installation is that each upgrade of v16 is wiping out the hostname setting for each domain. This has happened across 2 production and 1 test servers repeatedly.
 
Suddenly email fails to deliver because the update has wiped the hostname from each domain record... My admins are getting pretty tired of having to go through all the domains and reset this after every single upgrade.
Matthew J. Sine, General Manager8Dweb LLC"Making the Web a Happy Place"
0
Barbara Renowden Replied
Yes, I have noticed this as well.

Barbara Renowden President / Co-Founder Centric Web, Inc. https://www.centricweb.com

0
Tim Uzzanti Replied
Employee Post
We were able to replicate the issue and will have a fix out shortly.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread